summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMartin Pitt <martin.pitt@ubuntu.com>2009-05-09 12:26:01 +0200
committerMartin Pitt <martin.pitt@ubuntu.com>2009-05-09 12:26:01 +0200
commit6ab989b75d0c5b19967efe7001dd718a684ed592 (patch)
treed0cd701926748a567c2a904c2090b4355e5eb3ff /configure.ac
parent795dbb551a5b7e0f227cd6613afadc2fd22cf015 (diff)
configure.ac: check for gperf (required by keymap)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 45931b4..3e7ea79 100644
--- a/configure.ac
+++ b/configure.ac
@@ -23,6 +23,10 @@ PKG_CHECK_MODULES(USBUTILS, usbutils >= 0.82)
AC_SUBST([USB_DATABASE], [$($PKG_CONFIG --variable=usbids usbutils)])
AC_PATH_PROG([XSLTPROC], [xsltproc])
+AC_PATH_PROG([GPERF], [gperf])
+if test -z "$GPERF"; then
+ AC_MSG_ERROR(Could not find gperf)
+fi
AC_ARG_WITH(udev-prefix,
AS_HELP_STRING([--with-udev-prefix=DIR], [add prefix to internal udev path names]),
@@ -74,4 +78,5 @@ AC_MSG_RESULT([
ldflags: ${LDFLAGS}
xsltproc: ${XSLTPROC}
+ gperf: ${GPERF}
])