summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKay Sievers <kay.sievers@vrfy.org>2008-12-29 01:00:19 +0100
committerKay Sievers <kay.sievers@vrfy.org>2008-12-29 01:00:19 +0100
commit92209ed08e685ea17e32560570c3847e8da82077 (patch)
treecd7cba6eff4df94c0ec65189c6426343ffb4b203 /configure.ac
parent35e11fcc6fa1e8f44c2b3088dd7312325ffed4a4 (diff)
build: remove more autotools magic
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac35
1 files changed, 1 insertions, 34 deletions
diff --git a/configure.ac b/configure.ac
index d7f67d5..21f9b7d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -25,39 +25,6 @@ if test -n "$ac_macro_dir"; then
fi
AC_SUBST([ACLOCAL_AMFLAGS])
-dnl maintainer mode stuff
-if test $USE_MAINTAINER_MODE = yes; then
- DISABLE_DEPRECATED="-DG_DISABLE_DEPRECATED"
-else
- DISABLE_DEPRECATED=""
-fi
-AC_SUBST(DISABLE_DEPRECATED)
-
-dnl
-dnl Required headers
-dnl
-AC_HEADER_STDC
-AC_CHECK_HEADERS(fcntl.h paths.h sys/ioctl.h sys/time.h syslog.h unistd.h)
-
-dnl
-dnl Checks for typedefs, structures, and compiler characteristics.
-dnl
-AC_TYPE_MODE_T
-AC_TYPE_PID_T
-AC_HEADER_TIME
-
-dnl
-dnl Checks for library functions.
-dnl
-AC_PROG_GCC_TRADITIONAL
-AC_FUNC_MEMCMP
-AC_CHECK_FUNCS(select socket uname)
-
-dnl
-dnl Make sha1.c happy on big endian systems
-dnl
-AC_C_BIGENDIAN
-
PKG_CHECK_MODULES(GLIB, glib-2.0 >= 2.12)
AC_SUBST(GLIB_CFLAGS)
AC_SUBST(GLIB_LIBS)
@@ -71,7 +38,7 @@ AS_HELP_STRING([--enable-more-warnings], [Maximum compiler warnings]), set_more_
AC_MSG_CHECKING(for more warnings, including -Werror)
if test "$GCC" = "yes" -a "$set_more_warnings" != "no"; then
AC_MSG_RESULT(yes)
- CFLAGS="-Wall -Werror -std=gnu89 $CFLAGS"
+ CFLAGS="-Wall -Werror $CFLAGS"
for option in -Wshadow -Wmissing-declarations -Wmissing-prototypes \
-Wdeclaration-after-statement -Wstrict-prototypes \