summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMartin Pitt <martin.pitt@ubuntu.com>2009-05-10 22:24:38 +0200
committerMartin Pitt <martin.pitt@ubuntu.com>2009-05-10 22:24:38 +0200
commitda800c7ebbaf8d97cde9eb6d40d678ec92994077 (patch)
treeab8462d3f43043f15e2bc24d356cbc64b6d778cb /configure.ac
parent950cea7adef72497d39de0c71b8ef943b093125b (diff)
detect awk in configure (used by keymap)
keymap's Makefile uses awk. Instead of hardcoding it, use AC_PROG_AWK properly and use the detected one in the Makefiles. Thanks to Dan Nicholson for the suggestion.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index afe6740..3244f94 100644
--- a/configure.ac
+++ b/configure.ac
@@ -23,6 +23,7 @@ PKG_CHECK_MODULES(USBUTILS, usbutils >= 0.82)
AC_SUBST([USB_DATABASE], [$($PKG_CONFIG --variable=usbids usbutils)])
AC_PATH_PROG([XSLTPROC], [xsltproc])
+AC_PROG_AWK
AC_PATH_PROG([GPERF], [gperf])
if test -z "$GPERF"; then
AC_MSG_ERROR(Could not find gperf)