summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKay Sievers <kay.sievers@vrfy.org>2009-05-07 00:33:44 +0200
committerKay Sievers <kay.sievers@vrfy.org>2009-05-07 00:33:44 +0200
commitfa361b47d790c0ab63dc6c9d3bd18e8c437abbd6 (patch)
tree6903ad6bf85cb725a2403d108a34f67d6e5b826e /configure.ac
parent4817acf17ac15e0116ce12d66a14ca62e3bb7309 (diff)
depend on usbutils 0.82 and use pkg-config to find usb.ids
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 4 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index 27e0c22..ccf982d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
AC_INIT([udev-extras],
- [20090414],
+ [20090506],
[linux-hotplug@vger.kernel.org])
AC_PREREQ(2.60)
AM_INIT_AUTOMAKE([check-news foreign 1.9 subdir-objects dist-bzip2])
@@ -19,6 +19,9 @@ PKG_CHECK_MODULES(LIBUDEV, libudev >= 141)
AC_SUBST(LIBUDEV_CFLAGS)
AC_SUBST(LIBUDEV_LIBS)
+PKG_CHECK_MODULES(USBUTILS, usbutils >= 0.82)
+AC_SUBST([USB_DATABASE], [$($PKG_CONFIG --variable=usbids usbutils)])
+
AC_PATH_PROG([XSLTPROC], [xsltproc])
AC_ARG_WITH(udev-prefix,
@@ -29,19 +32,6 @@ AC_SUBST(udev_prefix)
AC_DEFINE(LIBUDEV_I_KNOW_THE_API_IS_SUBJECT_TO_CHANGE, 1, [I know the API is subject to change])
-AC_CHECK_FILES([/usr/share/usb.ids], [usbids=/usr/share/usb.ids])
-AC_CHECK_FILES([/usr/share/hwdata/usb.ids], [usbids=/usr/share/hwdata/usb.ids])
-AC_CHECK_FILES([/usr/share/misc/usb.ids], [usbids=/usr/share/misc/usb.ids])
-AC_ARG_WITH(usb-ids-path,
- AS_HELP_STRING([--usb-ids-path=DIR], [Path to usb.ids file]),
- [USB_DATABASE=${withval}],
- [if test -n "$usbids" ; then
- USB_DATABASE="$usbids"
- else
- AC_MSG_ERROR([usb.ids not found, try --with-usb-ids-path=])
- fi])
-AC_SUBST(USB_DATABASE)
-
AC_CHECK_FILES([/usr/share/pci.ids], [pciids=/usr/share/pci.ids])
AC_CHECK_FILES([/usr/share/hwdata/pci.ids], [pciids=/usr/share/hwdata/pci.ids])
AC_CHECK_FILES([/usr/share/misc/pci.ids], [pciids=/usr/share/misc/pci.ids])