summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 11681ac..0273ccc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -33,18 +33,18 @@ if type -p stow > /dev/null && test -d /usr/local/stow ; then
fi
# Checks for programs.
-AC_PROG_CXX
AC_PROG_CC
AC_PROG_LN_S
+AC_PROG_RANLIB
AC_PROG_LIBTOOL
-ACX_PTHREAD
-
-AC_TYPE_SIGNAL
-AC_HEADER_STDC
-AC_CHECK_FUNCS([memset strdup])
+AC_CHECK_FUNCS([gethostname])
+AC_CHECK_HEADERS([limits.h])
AC_C_CONST
AC_FUNC_MALLOC
+AC_TYPE_SIZE_T
+
+ACX_PTHREAD
if test -d ../polypaudio ; then
POLYP_CFLAGS='-I$(top_srcdir)/../polypaudio'