summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac75
1 files changed, 68 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 6d67ebd..948dc90 100644
--- a/configure.ac
+++ b/configure.ac
@@ -56,20 +56,81 @@ fi
AC_SUBST(PULSE_LIBS)
AC_SUBST(PULSE_CFLAGS)
-AC_PATH_PROG(XMMS_CONFIG, xmms-config)
-if test "x$XMMS_CONFIG" = "x" ; then
- AC_MSG_ERROR([*** Please install xmms-config of the xmms-dev package into your \$PATH ***])
+# XMMS plugin #
+
+AC_ARG_ENABLE([xmms],
+ AS_HELP_STRING([--disable-xmms],[Disable optional XMMS pluggin support]),
+ [
+ case "${enableval}" in
+ yes) xmms=true ;;
+ no) xmms=false ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --disable-xmms) ;;
+ esac
+ ],
+ [xmms=true])
+
+if test "x${xmms}" != xfalse ; then
+ AC_PATH_PROG(XMMS_CONFIG, xmms-config)
+ if test "x$XMMS_CONFIG" = "x" ; then
+ AC_MSG_ERROR([*** Please install xmms-config of the xmms-dev package into your \$PATH ***])
+ fi
+ XMMS_CFLAGS=`$XMMS_CONFIG --cflags`
+ XMMS_LIBS=`$XMMS_CONFIG --libs`
+ XMMS_OUTPUTPLUGINDIR=`$XMMS_CONFIG --output-plugin-dir`
+
+else
+ echo "*** XMMS disabled ***"
+ XMMS_CFLAGS=
+ XMMS_LIBS=
+ XMMS_OUTPUTPLUGINDIR=
fi
-XMMS_CFLAGS=`$XMMS_CONFIG --cflags`
-XMMS_LIBS=`$XMMS_CONFIG --libs`
-XMMS_OUTPUTPLUGINDIR=`$XMMS_CONFIG --output-plugin-dir`
-
AC_SUBST(XMMS_CFLAGS)
AC_SUBST(XMMS_LIBS)
AC_SUBST(XMMS_OUTPUTPLUGINDIR)
+AM_CONDITIONAL(BUILD_XMMS, test "x$xmms" = xtrue)
+
+
+# end of xmms #
+
+
+# BMP plugin #
+
+AC_ARG_ENABLE([bmp],
+ AS_HELP_STRING([--enable-bmp],[Enable optional Beep-Media-Player pluggin support]),
+ [
+ case "${enableval}" in
+ yes) bmp=true ;;
+ no) bmp=false ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-bmp) ;;
+ esac
+ ],
+ [bmp=false])
+
+if test "x${bmp}" != xfalse ; then
+ PKG_CHECK_MODULES(BMP, [ bmp >= 0.9.7 ])
+
+ BMP_CFLAGS="$BMP_CFLAGS -I/usr/include/bmp"
+ BMP_OUTPUTPLUGINDIR=`pkg-config bmp --variable=output_plugin_dir`
+
+else
+ echo "*** BMP disabled ***"
+ BMP_CFLAGS=
+ BMP_LIBS=
+ BMP_OUTPUTPLUGINDIR=
+fi
+
+AC_SUBST(BMP_CFLAGS)
+AC_SUBST(BMP_LIBS)
+AC_SUBST(BMP_OUTPUTPLUGINDIR)
+
+AM_CONDITIONAL(BUILD_BMP, test "x$bmp" = xtrue)
+
+# end of bmp #
+
+
# If using GCC specifiy some additional parameters
if test "x$GCC" = "xyes" ; then
CFLAGS="$CFLAGS -pipe -Wall -W -Wno-unused-parameter"