summaryrefslogtreecommitdiffstats
path: root/pam-ck-connector/Makefile.am
diff options
context:
space:
mode:
authorWilliam Jon McCann <mccann@jhu.edu>2007-03-01 14:24:27 -0500
committerWilliam Jon McCann <mccann@jhu.edu>2007-03-01 14:24:27 -0500
commit1d1b98cd17764be77b1aee79efae8e89ce7faa04 (patch)
treea7cb12bfcbf9061b26c9d274781d00361f4667fd /pam-ck-connector/Makefile.am
parente37a78dfc5abcb3b02cb5debaa24122fa9b949c4 (diff)
add a test program for the PAM module
Basically this is a mini login. It authenticates, opens a session, sleeps 20 seconds, and then closes the session.
Diffstat (limited to 'pam-ck-connector/Makefile.am')
-rw-r--r--pam-ck-connector/Makefile.am38
1 files changed, 34 insertions, 4 deletions
diff --git a/pam-ck-connector/Makefile.am b/pam-ck-connector/Makefile.am
index e03923b..3819f5e 100644
--- a/pam-ck-connector/Makefile.am
+++ b/pam-ck-connector/Makefile.am
@@ -1,17 +1,47 @@
+NULL =
if ENABLE_PAM_MODULE
-INCLUDES = $(LIBDBUS_CFLAGS) -I$(top_builddir)/libck-connector
+INCLUDES = \
+ $(LIBDBUS_CFLAGS) \
+ -I$(top_builddir)/libck-connector \
+ $(NULL)
+
+pamlibdir = /lib/security
+
+pamlib_LTLIBRARIES = \
+ pam_ck_connector.la \
+ $(NULL)
-pamlib_LTLIBRARIES=pam_ck_connector.la
-pamlibdir=/lib/security
pam_ck_connector_la_SOURCES = pam-ck-connector.c
pam_ck_connector_la_LDFLAGS = -no-undefined -module -avoid-version
-pam_ck_connector_la_LIBADD = -lpam $(LIBDBUS_LIBS) $(top_builddir)/libck-connector/libck-connector.la
+pam_ck_connector_la_LIBADD = \
+ $(PAM_LIBS) \
+ $(LIBDBUS_LIBS) \
+ $(top_builddir)/libck-connector/libck-connector.la \
+ $(NULL)
man_MANS = pam_ck_connector.8
+noinst_PROGRAMS = \
+ test-pam \
+ $(NULL)
+
+test_pam_SOURCES = \
+ test-pam.c \
+ $(NULL)
+
+test_pam_LDADD = \
+ $(PAM_LIBS) \
+ -lpam_misc \
+ $(NULL)
+
endif
+MAINTAINERCLEANFILES = \
+ *~ \
+ Makefile.in \
+ $(NULL)
+
clean-local :
rm -f *~