summaryrefslogtreecommitdiffstats
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorWilliam Jon McCann <jmccann@redhat.com>2008-02-11 15:31:42 -0500
committerWilliam Jon McCann <jmccann@redhat.com>2008-02-11 15:31:42 -0500
commit685f2cbf9d69da556907ba6c935fe6ab1d2eeda3 (patch)
treeadc9f5666d3c71f0af0eac993d62c61d39f171a6 /tools/Makefile.am
parente2fa0c66a6ef8dafa8b503d0b077deb17f3fc512 (diff)
add a ck-launch-session tool
This tool opens a session with ConsoleKit and runs a command in it.
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index 1fe0f6b..2cf66db 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -28,6 +28,7 @@ INCLUDES = \
-I. \
-I$(srcdir) \
-I$(top_srcdir)/src \
+ -I$(top_builddir)/libck-connector \
$(CONSOLE_KIT_CFLAGS) \
$(DISABLE_DEPRECATED_CFLAGS) \
-DPREFIX=\""$(prefix)"\" \
@@ -44,6 +45,7 @@ INCLUDES = \
$(NULL)
bin_PROGRAMS = \
+ ck-launch-session \
ck-list-sessions \
ck-history \
$(NULL)
@@ -54,6 +56,15 @@ sbin_PROGRAMS = \
ck-log-system-stop \
$(NULL)
+ck_launch_session_SOURCES = \
+ ck-launch-session.c \
+ $(NULL)
+
+ck_launch_session_LDADD = \
+ $(top_builddir)/libck-connector/libck-connector.la \
+ $(CONSOLE_KIT_LIBS) \
+ $(NULL)
+
ck_list_sessions_SOURCES = \
list-sessions.c \
$(NULL)