summaryrefslogtreecommitdiffstats
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorWilliam Jon McCann <mccann@jhu.edu>2007-08-14 17:03:00 -0400
committerWilliam Jon McCann <mccann@jhu.edu>2007-08-14 17:03:00 -0400
commite56a95f64c9c9f57adebf6cb3e6c88790cec40e4 (patch)
tree0cb197ebc031483cb9eaa74d41801b6bda6887a3 /tools/Makefile.am
parentdc97e6caabc9932922d26f3400424626462f5ad2 (diff)
move tools out of linux subdirectory since they apparently work on solaris
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index b7f515a..98783eb 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -17,6 +17,7 @@ DIST_SUBDIRS = \
INCLUDES = \
-I. \
-I$(srcdir) \
+ -I$(top_srcdir)/src \
$(CONSOLE_KIT_CFLAGS) \
$(DISABLE_DEPRECATED_CFLAGS) \
-DPREFIX=\""$(prefix)"\" \
@@ -42,6 +43,41 @@ ck_list_sessions_LDADD = \
$(CONSOLE_KIT_LIBS) \
$(NULL)
+
+libexec_PROGRAMS = \
+ ck-collect-session-info \
+ ck-get-x11-server-pid \
+ ck-get-x11-display-device \
+ $(NULL)
+
+ck_collect_session_info_SOURCES = \
+ ck-collect-session-info.c \
+ $(NULL)
+
+ck_collect_session_info_LDADD = \
+ $(TOOLS_LIBS) \
+ $(top_builddir)/src/libckproc.la\
+ $(NULL)
+
+ck_get_x11_server_pid_SOURCES = \
+ ck-get-x11-server-pid.c \
+ $(NULL)
+
+ck_get_x11_server_pid_LDADD = \
+ $(TOOLS_LIBS) \
+ $(top_builddir)/src/libckproc.la\
+ $(NULL)
+
+ck_get_x11_display_device_SOURCES = \
+ ck-get-x11-display-device.c \
+ $(NULL)
+
+ck_get_x11_display_device_LDADD = \
+ $(TOOLS_LIBS) \
+ $(top_builddir)/src/libckproc.la\
+ $(NULL)
+
+
EXTRA_DIST = \
$(NULL)