summaryrefslogtreecommitdiffstats
path: root/input/Makefile.am
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2007-01-23 07:18:07 +0000
committerMarcel Holtmann <marcel@holtmann.org>2007-01-23 07:18:07 +0000
commit77a277e66743cd5f55cec8e4b5e61874bb6ab5b0 (patch)
tree03d21dfaf0fb6ea8fffc5ff1d0fd92b2b6c02d61 /input/Makefile.am
parent7a0e09996a2d86045c5a2cfc847f9c49d64ae511 (diff)
Make echo and input service configurable
Diffstat (limited to 'input/Makefile.am')
-rw-r--r--input/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/input/Makefile.am b/input/Makefile.am
index 7716bec6..6aa8ef1b 100644
--- a/input/Makefile.am
+++ b/input/Makefile.am
@@ -1,7 +1,14 @@
+if INPUTSERVICE
+if CONFIGFILES
+confdir = $(sysconfdir)/bluetooth
+
+conf_DATA = input.service
+endif
+
servicedir = $(libdir)/bluetooth
-noinst_PROGRAMS = bluetoothd-service-input
+service_PROGRAMS = bluetoothd-service-input
bluetoothd_service_input_SOURCES = \
main.c server.h server.c \
@@ -9,6 +16,7 @@ bluetoothd_service_input_SOURCES = \
LDADD = $(top_builddir)/common/libhelper.a \
@GLIB_LIBS@ @DBUS_LIBS@ @BLUEZ_LIBS@
+endif
AM_CFLAGS = @BLUEZ_CFLAGS@ @DBUS_CFLAGS@ @GLIB_CFLAGS@