summaryrefslogtreecommitdiffstats
path: root/input/Makefile.am
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2007-01-20 05:26:15 +0000
committerMarcel Holtmann <marcel@holtmann.org>2007-01-20 05:26:15 +0000
commit8cc5595d9091b484b9a4abe314c0f3ec055e0581 (patch)
tree0d20c6f621673dbdb6095fb4854077152c1d9b40 /input/Makefile.am
parent884cfe825db1a0e8c98aa6a604fd4588a1de1340 (diff)
Make it possible to support an embedded GLib
Diffstat (limited to 'input/Makefile.am')
-rw-r--r--input/Makefile.am14
1 files changed, 3 insertions, 11 deletions
diff --git a/input/Makefile.am b/input/Makefile.am
index e9efa972..6565d8c1 100644
--- a/input/Makefile.am
+++ b/input/Makefile.am
@@ -7,23 +7,15 @@ endif
servicedir = $(libdir)/bluetooth
-if GLIB
-glib_cflags = @GLIB_CFLAGS@
-glib_ldadd = @GLIB_LIBS@
-else
-glib_cflags =
-glib_ldadd =
-endif
-
noinst_PROGRAMS = bluetoothd-service-input
bluetoothd_service_input_SOURCES = \
main.c input-service.h input-service.c
-LDADD = $(top_builddir)/common/libhelper.a $(glib_ldadd) \
- @DBUS_LIBS@ @BLUEZ_LIBS@
+LDADD = $(top_builddir)/common/libhelper.a \
+ @GLIB_LIBS@ @DBUS_LIBS@ @BLUEZ_LIBS@
-AM_CFLAGS = @BLUEZ_CFLAGS@ @DBUS_CFLAGS@ $(glib_cflags)
+AM_CFLAGS = @BLUEZ_CFLAGS@ @DBUS_CFLAGS@ @GLIB_CFLAGS@
INCLUDES = -I$(top_srcdir)/common