summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid I. Lehn <dlehn@users.sourceforge.net>2002-12-05 00:25:13 +0000
committerDavid I. Lehn <dlehn@users.sourceforge.net>2002-12-05 00:25:13 +0000
commitc7e109241fd4789092166cf04484c6bc113cbbd6 (patch)
tree47e4cb77831372b70a53e2682e497f7a40edde92 /Makefile.am
parenta03ceeadcbf4c99be28f9daa7c667ff1ce07a6af (diff)
examples should build conditionally
Original commit message from CVS: examples should build conditionally
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 54500858..696b60d5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -10,13 +10,19 @@ else
EXT_DIR=
endif
+if BUILD_EXAMPLES
+EXAMPLES_DIR=examples
+else
+EXAMPLES_DIR=
+endif
+
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = gstreamer-libs.pc gstreamer-play.pc
aclocaldir = $(datadir)/aclocal
aclocal_DATA = gst-element-check.m4
-SUBDIRS=gst-libs gst sys $(EXT_DIR) examples tools $(GCONF_DIR) testsuite
+SUBDIRS=gst-libs gst sys $(EXT_DIR) $(EXAMPLES_DIR) tools $(GCONF_DIR) testsuite
DIST_SUBDIRS=gst-libs gst sys ext examples tools gconf testsuite