summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2002-12-08 14:50:09 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2002-12-08 14:50:09 +0000
commite16c50551bed9fb6ad68965bcf739200429b6bf7 (patch)
tree572909f401bc3a50267a593fe95760e60e57f933 /Makefile.am
parent17a38e044e460583939084ad864d5208bd6f2d94 (diff)
parallel install fixes
Original commit message from CVS: parallel install fixes
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 11 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 696b60d5..cd4a884a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -16,11 +16,20 @@ else
EXAMPLES_DIR=
endif
+gstreamer-libs-@GST_MAJORMINOR@.pc: gstreamer-libs.pc
+ cp gstreamer-libs.pc gstreamer-libs-@GST_MAJORMINOR@.pc
+gstreamer-play-@GST_MAJORMINOR@.pc: gstreamer-play.pc
+ cp gstreamer-play.pc gstreamer-play-@GST_MAJORMINOR@.pc
+gst_element_check-@GST_MAJORMINOR@.m4: gst-element-check.m4
+ cp gst-element-check.m4 gst-element-check-@GST_MAJORMINOR@.m4
+
pkgconfigdir = $(libdir)/pkgconfig
-pkgconfig_DATA = gstreamer-libs.pc gstreamer-play.pc
+pkgconfig_DATA = \
+ gstreamer-libs-@GST_MAJORMINOR@.pc \
+ gstreamer-play-@GST_MAJORMINOR@.pc
aclocaldir = $(datadir)/aclocal
-aclocal_DATA = gst-element-check.m4
+aclocal_DATA = gst-element-check-@GST_MAJORMINOR@.m4
SUBDIRS=gst-libs gst sys $(EXT_DIR) $(EXAMPLES_DIR) tools $(GCONF_DIR) testsuite