summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Schleef <ds@schleef.org>2004-01-07 10:51:05 +0000
committerDavid Schleef <ds@schleef.org>2004-01-07 10:51:05 +0000
commit0adc28bcb89219250977c600cab68777f24114ab (patch)
treeb6adc0f187dad6851d2c223b9a4c3a096c901c77 /configure.ac
parent1756816071157e3f837eaabba8453e1b453a91d4 (diff)
New source plugin based on librfb-0.1. RFB (remote framebuffer) is the protocol used by VNC.
Original commit message from CVS: New source plugin based on librfb-0.1. RFB (remote framebuffer) is the protocol used by VNC.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 716a1562..dd1f2082 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1037,6 +1037,13 @@ GST_CHECK_FEATURE(LIBPNG, [libpng PNG encoder], pngenc, [
AC_SUBST(LIBPNG_LIBS)
])
+dnl *** librfb ***
+translit(dnm, m, l) AM_CONDITIONAL(USE_LIBRFB, true)
+GST_CHECK_FEATURE(LIBRFB, [librfb Remote Framebuffer], rfbsrc, [
+ PKG_CHECK_MODULES(LIBRFB, librfb-0.1, HAVE_LIBRFB="yes", HAVE_LIBRFB="no")
+ AC_SUBST(LIBRFB_CFLAGS)
+ AC_SUBST(LIBRFB_LIBS)
+])
dnl *** mad ***
dnl FIXME: we could use header checks here as well IMO
@@ -1609,6 +1616,7 @@ ext/ivorbis/Makefile
ext/lcs/Makefile
ext/libfame/Makefile
ext/libpng/Makefile
+ext/librfb/Makefile
ext/mad/Makefile
ext/mas/Makefile
ext/mikmod/Makefile