summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSebastian Dröge <slomo@circular-chaos.org>2008-01-10 12:25:44 +0000
committerSebastian Dröge <slomo@circular-chaos.org>2008-01-10 12:25:44 +0000
commit1355ae0c97d73ea874c33f19ff99492e83c69355 (patch)
treee49dbf8b5552723a228c8712ae467e45a21f0834 /configure.ac
parenta860efa4c3d56206db5c8784c28d7877d7e5e92a (diff)
autogen.sh: Add -Wno-portability to the automake parameters to stop warnings about GNU make extensions being used. We...
Original commit message from CVS: * autogen.sh: Add -Wno-portability to the automake parameters to stop warnings about GNU make extensions being used. We require GNU make in almost every Makefile anyway. * configure.ac: Use AM_PROG_CC_C_O as a compiler that accepts both -c and -o at the same time is required for per target flags.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5d233bfb..d0153d0d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -167,6 +167,9 @@ AC_PROG_CXXCPP
AS_PROG_OBJC
+dnl check if the compiler supports '-c' and '-o' options
+AM_PROG_CC_C_O
+
AC_PATH_PROG(VALGRIND_PATH, valgrind, no)
AM_CONDITIONAL(HAVE_VALGRIND, test ! "x$VALGRIND_PATH" = "xno")