summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2004-10-04 15:11:49 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2004-10-04 15:11:49 +0000
commit1d0ae896fd852c5f7f77c4eb952dd03627f657ba (patch)
tree262eb75be01901de6a26b5362d948752540e42df /configure.ac
parent134a5deecb2a69418886e13fd7de2ddc261cf566 (diff)
you need 1.0.4 of speex
Original commit message from CVS: you need 1.0.4 of speex
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 11 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index cba07ad1..270d67e5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1432,7 +1432,7 @@ GST_CHECK_FEATURE(LIBPNG, [snapshot plug-in], snapshot, [
AC_SUBST(LIBPNG_LIBS)
])
-dnl *** speex 1.0.x or >= 1.1.5 ***
+dnl *** speex >= 1.0.4 or >= 1.1.5 ***
dnl 1.1.4 and earlier were not API/ABI compatible with 1.0
dnl 1.1.6 is the first to use a .pc/pkg-config file ***
dnl speex_jitter.h is 1.1.x only
@@ -1455,12 +1455,17 @@ GST_CHECK_FEATURE(SPEEX, [speex plug-in], speex, [
],[
HAVE_SPEEX="no"
])
- ], [
+ ],[
dnl speex 1.0.x :
- HAVE_SPEEX="yes"
- SPEEX_LIBS="-lspeex"
- AC_SUBST(SPEEX_CFLAGS)
- AC_SUBST(SPEEX_LIBS)
+ AC_CHECK_DECL(SPEEX_GET_LOOKAHEAD, [
+ dnl speex 1.0.4
+ HAVE_SPEEX="yes"
+ SPEEX_LIBS="-lspeex"
+ AC_SUBST(SPEEX_CFLAGS)
+ AC_SUBST(SPEEX_LIBS)
+ ],[
+ AC_MSG_NOTICE(You need at least 1.0.4 to compile the speex plugin)
+ ])
])
])
])