summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRamon Garcia Fernandez <ramon_garcia_f@yahoo.com>2004-02-22 01:53:40 +0000
committerRamon Garcia Fernandez <ramon_garcia_f@yahoo.com>2004-02-22 01:53:40 +0000
commit22804fbead619cd0d9e3b4647dd4c42a5b4456fb (patch)
tree93dbf65225a522594867ea050c1721d05bec2005 /configure.ac
parentedb7a6c6f11ee0c1f1833655938faf4fb90362e4 (diff)
Export only gst_plugin_desc from plugins
Original commit message from CVS: Export only gst_plugin_desc from plugins
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index a54e0b61..1cc668fc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -65,7 +65,7 @@ dnl decide on error flags
AS_COMPILER_FLAG(-Wall, GST_WALL="yes", GST_WALL="no")
if test "x$GST_WALL" = "xyes"; then
- GST_ERROR="$GST_ERROR -Wall"
+ GST_ERROR="$GST_ERROR -Wall -Wno-sign-compare"
if test "x$GST_CVS" = "xyes"; then
AS_COMPILER_FLAG(-Werror,GST_ERROR="$GST_ERROR -Werror",GST_ERROR="$GST_ERROR")
@@ -326,7 +326,7 @@ dnl ===========================================================================
plugindir="\$(libdir)/gstreamer-$GST_MAJORMINOR"
AC_SUBST(plugindir)
-GST_PLUGIN_LDFLAGS='-module -avoid-version'
+GST_PLUGIN_LDFLAGS='-module -avoid-version -export-symbols-regex gst_plugin_desc'
AC_SUBST(GST_PLUGIN_LDFLAGS)
dnl these are all the gst plug-ins, compilable without additional libs