summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2004-08-30 10:26:52 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2004-08-30 10:26:52 +0000
commit5daae0674580ee626bcd030afea387ce00811c16 (patch)
tree075f6fbb4688a990d0de74d141b03e7699c8d66c /configure.ac
parent2cf60029a100640050e6dfae9a9698817f4702d3 (diff)
fix for 151236
Original commit message from CVS: fix for 151236
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 1a5ff31a..9766ee1f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -675,8 +675,8 @@ GST_CHECK_FEATURE(V4L, [Video 4 Linux], v4lsrc v4lmjpegsrc v4lmjpegsink, [
dnl *** Video 4 Linux 2 ***
dnl for information about the header/define, see sys/v4l2/gstv4l2element.h
translit(dnm, m, l) AM_CONDITIONAL(USE_V4L2, true)
-GST_CHECK_FEATURE(V4L2, [Video 4 Linux 2], v4l2src, [
- HAVE_V4L2="no"
+GST_CHECK_FEATURE(GST_V4L2, [Video 4 Linux 2], v4l2src, [
+ HAVE_GST_V4L2="no"
if test "$HAVE_X" = "yes"
then
AC_MSG_CHECKING([Checking for uptodate v4l2 installation])
@@ -690,15 +690,15 @@ GST_CHECK_FEATURE(V4L2, [Video 4 Linux 2], v4l2src, [
#endif
], [
return 0;
- ], [ HAVE_V4L2="yes" && AC_MSG_RESULT(yes)],
- [ HAVE_V4L2="no" && AC_MSG_RESULT(no) &&
+ ], [ HAVE_GST_V4L2="yes" && AC_MSG_RESULT(yes)],
+ [ HAVE_GST_V4L2="no" && AC_MSG_RESULT(no) &&
AC_CHECK_HEADER(linux/videodev2.h,
[ AC_MSG_WARN([video4linux2 headers were found, but they're old. Please update v4l2 to compile the v4l2 plugins])],
[ AC_MSG_WARN([video4linux2 was not found])])
])
fi
dnl check for missing v4l2_buffer declaration (see #135919)
- if [ test x$HAVE_V4L2 = xyes ]; then
+ if [ test x$HAVE_GST_V4L2 = xyes ]; then
MISSING_DECL=0
AC_MSG_CHECKING(struct v4l2_buffer declaration)
AC_TRY_COMPILE([