summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2004-02-13 13:09:27 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2004-02-13 13:09:27 +0000
commit7ae3469e1c90970099821636e02c6c23c255edf7 (patch)
treef4eba42a1126094194f21c5e8f0474c355390372 /configure.ac
parentfc9738517b25b7b43800e60bd1423f11538323d5 (diff)
use GST_ARCH
Original commit message from CVS: use GST_ARCH
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac36
1 files changed, 3 insertions, 33 deletions
diff --git a/configure.ac b/configure.ac
index 75bf8c71..220a8499 100644
--- a/configure.ac
+++ b/configure.ac
@@ -149,6 +149,9 @@ AC_ARG_WITH(pkg-config-path,
AC_HELP_STRING([--with-pkg-config-path],[colon-separated list of pkg-config(1) dirs]),
[export PKG_CONFIG_PATH=${withval}])
+dnl check architecture
+GST_ARCH()
+
dnl Check for nasm
AC_PATH_PROG(NASM_PATH, nasm, no)
AC_SUBST(NASM_PATH)
@@ -206,39 +209,6 @@ fi
AC_SUBST(GST_CONTROL_LIBS)
-dnl Set up conditionals for (target) architecture:
-dnl ==============================================
-
-dnl Determine CPU
-case "x${target_cpu}" in
- xi?86 | k?) HAVE_CPU_I386=yes
- AC_DEFINE(HAVE_CPU_I386, 1, [Define if the target CPU is an x86])
- dnl FIXME could use some better detection
- dnl (ie CPUID)
- case "x${target_cpu}" in
- xi386 | xi486) ;;
- *) AC_DEFINE(HAVE_RDTSC, 1, [Define if RDTSC is available]) ;;
- esac ;;
- xpowerpc) HAVE_CPU_PPC=yes
- AC_DEFINE(HAVE_CPU_PPC, 1, [Define if the target CPU is a PPC]) ;;
- xalpha) HAVE_CPU_ALPHA=yes
- AC_DEFINE(HAVE_CPU_ALPHA, 1, [Define if the target CPU is an Alpha]) ;;
- xarm*) HAVE_CPU_ARM=yes
- AC_DEFINE(HAVE_CPU_ARM, 1, [Define if the target CPU is an ARM]) ;;
- xsparc*) HAVE_CPU_SPARC=yes
- AC_DEFINE(HAVE_CPU_SPARC, 1, [Define if the target CPU is a PPC]) ;;
- xmips*) HAVE_CPU_MIPS=yes
- AC_DEFINE(HAVE_CPU_MIPS, 1, [Define if the target CPU is a MIPS]) ;;
- xhppa*) HAVE_CPU_HPPA=yes
- AC_DEFINE(HAVE_CPU_HPPA, 1, [Define if the target CPU is a HPPA]) ;;
-esac
-# make these available to automake
-AM_CONDITIONAL(HAVE_CPU_I386, test "x$HAVE_CPU_I386" = "xyes")
-AM_CONDITIONAL(HAVE_CPU_PPC, test "x$HAVE_CPU_PPC" = "xyes")
-AM_CONDITIONAL(HAVE_CPU_ALPHA, test "x$HAVE_CPU_ALPHA" = "xyes")
-AM_CONDITIONAL(HAVE_CPU_ARM, test "x$HAVE_CPU_ARM" = "xyes")
-AM_CONDITIONAL(HAVE_CPU_SPARC, test "x$HAVE_CPU_SPARC" = "xyes")
-
dnl Determine endianness
AC_C_BIGENDIAN