summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Schmidt <thaytan@mad.scientist.com>2007-06-08 17:37:02 +0000
committerJan Schmidt <thaytan@mad.scientist.com>2007-06-08 17:37:02 +0000
commit853a9f7fe9956bf6afe10694bdb3def96cf046b7 (patch)
treee68308f64688ca7f5b509c770dce83747daceffe /configure.ac
parent01877c67b12a10bfb0520469476c592570e9e647 (diff)
Add DirectDraw & DirectSound plugins to the build and docs.
Original commit message from CVS: * configure.ac: * docs/plugins/Makefile.am: * docs/plugins/gst-plugins-good-plugins-docs.sgml: * docs/plugins/gst-plugins-good-plugins-sections.txt: * docs/plugins/gst-plugins-good-plugins.args: * sys/Makefile.am: * win32/MANIFEST: Add DirectDraw & DirectSound plugins to the build and docs.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac85
1 files changed, 85 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 74d913f2..1a22cbaa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -347,6 +347,87 @@ echo
AC_MSG_NOTICE([Checking libraries for plugins in sys/])
echo
+dnl DirectDraw
+translit(dnm, m, l) AM_CONDITIONAL(USE_DIRECTDRAW, true)
+AG_GST_CHECK_FEATURE(DIRECTDRAW, [DirectDraw plug-in], directdrawsink, [
+ HAVE_DIRECTDRAW="no"
+ save_CFLAGS="$CFLAGS"
+ save_LDFLAGS="$LDFLAGS"
+ save_LIBS="$LIBS"
+ CFLAGS="$CFLAGS $DIRECTDRAW_CFLAGS"
+ LDFLAGS="$LDFLAGS $DIRECTDRAW_LDFLAGS"
+ LIBS="$LIBS -lddraw -lgdi32"
+ AC_MSG_CHECKING(for DirectDraw LDFLAGS)
+ AC_LINK_IFELSE([
+#include <windows.h>
+#include <ddraw.h>
+
+int main ()
+{
+ GetStockObject(0);
+ DirectDrawCreate(NULL, NULL, NULL);
+
+ return 0;
+}
+],
+ [HAVE_DIRECTDRAW="yes"],
+ [HAVE_DIRECTDRAW="no"])
+ AC_MSG_RESULT($HAVE_DIRECTDRAW)
+ CFLAGS=$save_CFLAGS
+ LDFLAGS=$save_LDFLAGS
+ LIBS=$save_LIBS
+
+ if test "x$HAVE_DIRECTDRAW" = "xyes"; then
+ dnl this is much more than we want
+ DIRECTDRAW_LIBS="-lddraw -ldxguid -lgdi32"
+ AC_SUBST(DIRECTDRAW_CFLAGS)
+ AC_SUBST(DIRECTDRAW_LDFLAGS)
+ AC_SUBST(DIRECTDRAW_LIBS)
+ fi
+ AC_SUBST(HAVE_DIRECTDRAW)
+])
+
+dnl DirectSound
+translit(dnm, m, l) AM_CONDITIONAL(USE_DIRECTSOUND, true)
+AG_GST_CHECK_FEATURE(DIRECTSOUND, [DirectSound plug-in], directsoundsink, [
+ HAVE_DIRECTSOUND="no"
+ save_CFLAGS="$CFLAGS"
+ save_LDFLAGS="$LDFLAGS"
+ save_LIBS="$LIBS"
+ CFLAGS="$CFLAGS $DIRECTSOUND_CFLAGS"
+ LDFLAGS="$LDFLAGS $DIRECTSOUND_LDFLAGS"
+ LIBS="$LIBS -ldsound -ldxerr9"
+ AC_MSG_CHECKING(for DirectSound LDFLAGS)
+ AC_LINK_IFELSE([
+#include <windows.h>
+#include <dxerr9.h>
+#include <dsound.h>
+
+int main ()
+{
+ DXGetErrorString9 (0);
+ DirectSoundCreate(NULL, NULL, NULL);
+
+ return 0;
+}
+],
+ [HAVE_DIRECTSOUND="yes"],
+ [HAVE_DIRECTSOUND="no"])
+ AC_MSG_RESULT($HAVE_DIRECTSOUND)
+ CFLAGS=$save_CFLAGS
+ LDFLAGS=$save_LDFLAGS
+ LIBS=$save_LIBS
+
+ if test "x$HAVE_DIRECTSOUND" = "xyes"; then
+ dnl this is much more than we want
+ DIRECTSOUND_LIBS="-ldsound -ldxerr9"
+ AC_SUBST(DIRECTSOUND_CFLAGS)
+ AC_SUBST(DIRECTSOUND_LDFLAGS)
+ AC_SUBST(DIRECTSOUND_LIBS)
+ fi
+ AC_SUBST(HAVE_DIRECTSOUND)
+])
+
dnl *** OSS audio *** (Linux, *BSD)
translit(dnm, m, l) AM_CONDITIONAL(USE_OSS, true)
AG_GST_CHECK_FEATURE(OSS, [OSS audio], ossaudio, [
@@ -784,6 +865,8 @@ else
dnl not building plugins with external dependencies,
dnl but we still need to set the conditionals
AM_CONDITIONAL(USE_GCONFTOOL, false)
+AM_CONDITIONAL(USE_DIRECTDRAW, false)
+AM_CONDITIONAL(USE_DIRECTSOUND, false)
AM_CONDITIONAL(USE_OSS, false)
AM_CONDITIONAL(USE_SUNAUDIO, false)
AM_CONDITIONAL(USE_OSX_AUDIO, false)
@@ -908,6 +991,8 @@ ext/shout2/Makefile
ext/speex/Makefile
ext/taglib/Makefile
sys/Makefile
+sys/directdraw/Makefile
+sys/directsound/Makefile
sys/oss/Makefile
sys/sunaudio/Makefile
sys/osxaudio/Makefile