summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gmail.com>2008-12-07 19:01:35 +0000
committerSebastian Dröge <slomo@circular-chaos.org>2008-12-07 19:01:35 +0000
commit9f2e7127dc338e3cc6287ab87caa2c0449290ec2 (patch)
tree9238c19509d1ff6172a253c349995f80742ab108 /configure.ac
parentc54c9e2bac515f61f1ab0632be279d8c72764586 (diff)
configure.ac: Make usage of libv4l optional by a configure parameter.
Original commit message from CVS: Patch by: Alexandre Rostovtsev <tetromino at gmail dot com> * configure.ac: Make usage of libv4l optional by a configure parameter. Fixes bug #563504.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 17 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index c7e0c9a0..473a7aaa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -550,14 +550,24 @@ return 0;
fi
])
+# Make libv4l2 non-automagic
+AC_ARG_WITH([libv4l2],
+ AC_HELP_STRING([--with-libv4l2],
+ [support video buffer conversion using libv4l2]),
+ [],
+ [with_libv4l2=check])
if test x$HAVE_GST_V4L2 = xyes; then
- PKG_CHECK_MODULES(LIBV4L2, libv4l2,
- [ have_libv4l2=yes
- AC_DEFINE(HAVE_LIBV4L2, 1,
- [Whether libv4l2 is available for video buffer conversion])
- ], [
- have_libv4l2=no
- ])
+ if test x$with_libv4l2 != xno; then
+ PKG_CHECK_MODULES(LIBV4L2, libv4l2,
+ [ have_libv4l2=yes
+ AC_DEFINE(HAVE_LIBV4L2, 1,
+ [Whether libv4l2 is available for video buffer conversion])
+ ], [
+ have_libv4l2=no
+ ])
+ else
+ have_libv4l2=no
+ fi
fi
dnl Check for X11