summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Schmidt <thaytan@mad.scientist.com>2007-06-12 20:15:29 +0000
committerJan Schmidt <thaytan@mad.scientist.com>2007-06-12 20:15:29 +0000
commitbbcc24410daed9b6cbbe0efac8d28c4ff4f7da0f (patch)
tree9fe7951f6f0cf989cfad6d5e0eb660d2042d60c2 /configure.ac
parent98ef159bd144b4c50e5c5bad59abc4c180ff1e79 (diff)
Move videocrop and osxvideo from -bad.
Original commit message from CVS: * configure.ac: * docs/plugins/Makefile.am: * docs/plugins/gst-plugins-good-plugins-docs.sgml: * docs/plugins/gst-plugins-good-plugins-sections.txt: * docs/plugins/inspect/plugin-videocrop.xml: * gst-plugins-good.spec.in: * sys/Makefile.am: * tests/check/Makefile.am: * tests/icles/Makefile.am: * tests/icles/videocrop-test.c: Move videocrop and osxvideo from -bad.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e4e8fd8a..f04c12bc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -104,6 +104,7 @@ GST_PLUGINS_ALL="\
smpte \
udp \
videobox \
+ videocrop \
videomixer \
wavenc \
wavparse \
@@ -467,6 +468,22 @@ AG_GST_CHECK_FEATURE(OSX_AUDIO, [OSX audio], osxaudio, [
AC_CHECK_HEADER(CoreAudio/CoreAudio.h, HAVE_OSX_AUDIO="yes", HAVE_OSX_AUDIO="no")
])
+dnl *** OS X video ***
+translit(dnm, m, l) AM_CONDITIONAL(USE_OSX_VIDEO, true)
+HAVE_OSX_VIDEO="no"
+AG_GST_CHECK_FEATURE(OSX_VIDEO, [OSX video], osxvideosink, [
+ AC_CHECK_HEADER(OpenGL/gl.h, HAVE_OSX_VIDEO="yes", HAVE_OSX_VIDEO="no")
+])
+dnl in case header OpenGL/gl.h is found on other platforms
+case "$host" in
+ *-*darwin*)
+ dnl do nothing
+ ;;
+ *)
+ HAVE_OSX_VIDEO="no"
+ ;;
+esac
+
dnl *** Video 4 Linux 2 ***
dnl for information about the header/define, see sys/v4l2/gstv4l2element.h
@@ -908,6 +925,7 @@ AM_CONDITIONAL(USE_DIRECTSOUND, false)
AM_CONDITIONAL(USE_OSS, false)
AM_CONDITIONAL(USE_SUNAUDIO, false)
AM_CONDITIONAL(USE_OSX_AUDIO, false)
+AM_CONDITIONAL(USE_OSX_VIDEO, false)
AM_CONDITIONAL(USE_X, false)
AM_CONDITIONAL(USE_XSHM, false)
AM_CONDITIONAL(USE_AALIB, false)
@@ -1006,6 +1024,7 @@ gst/rtsp/Makefile
gst/smpte/Makefile
gst/udp/Makefile
gst/videobox/Makefile
+gst/videocrop/Makefile
gst/videofilter/Makefile
gst/videomixer/Makefile
gst/wavenc/Makefile
@@ -1037,6 +1056,7 @@ sys/directsound/Makefile
sys/oss/Makefile
sys/sunaudio/Makefile
sys/osxaudio/Makefile
+sys/osxvideo/Makefile
sys/v4l2/Makefile
sys/ximage/Makefile
po/Makefile.in