summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorStefan Kost <ensonic@users.sourceforge.net>2007-02-11 10:53:21 +0000
committerStefan Kost <ensonic@users.sourceforge.net>2007-02-11 10:53:21 +0000
commite687b50f6259b2621b309e070e250d99552350fa (patch)
tree750aabb871b90683d9e202f72d85902be3dc3a15 /configure.ac
parentd8f5483d85ca53fb6b85c66352aaced527587c32 (diff)
configure.ac: Activate monoscope when building with --enable-experimental. Fix
Original commit message from CVS: * configure.ac: Activate monoscope when building with --enable-experimental. Fix --enable-external configure switch description. * sys/sunaudio/gstsunaudiomixer.c: (gst_sunaudiomixer_base_init): * sys/sunaudio/gstsunaudiosrc.c: (gst_sunaudiosrc_dispose): Help gst-indent.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 3 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index ae43de2d..0bb1f372 100644
--- a/configure.ac
+++ b/configure.ac
@@ -138,13 +138,8 @@ if test "x$HAVE_WINSOCK2_H" = "xyes"; then
AC_SUBST(WIN32_LIBS)
fi
-dnl disable monoscope plugin
-GST_PLUGINS_SELECTED=`echo $GST_PLUGINS_SELECTED | $SED -e s/monoscope//`
-
-AC_SUBST(GST_PLUGINS_SELECTED)
-
dnl ext plug-ins; plug-ins that have external dependencies
-GST_CHECK_FEATURE(EXTERNAL, [enable building of plug-ins with external deps],,
+GST_CHECK_FEATURE(EXTERNAL, [building of plug-ins with external deps],,
[HAVE_EXTERNAL=yes], enabled,
[
AC_MSG_NOTICE(building external plug-ins)
@@ -164,8 +159,10 @@ GST_CHECK_FEATURE(EXPERIMENTAL, [enable building of experimental plug-ins],,
],[
AC_MSG_NOTICE(not building experimental plug-ins)
USE_GST_V4L2="no"
+ GST_PLUGINS_SELECTED=`echo $GST_PLUGINS_SELECTED | $SED -e s/monoscope//`
])
+AC_SUBST(GST_PLUGINS_SELECTED)
dnl *** checks for platform ***