summaryrefslogtreecommitdiffstats
path: root/ext/Makefile.am
diff options
context:
space:
mode:
authorRonald S. Bultje <rbultje@ronald.bitfreak.net>2004-11-07 18:30:06 +0000
committerRonald S. Bultje <rbultje@ronald.bitfreak.net>2004-11-07 18:30:06 +0000
commit44fd8700290d4147f21a1384ddb6478a529361ee (patch)
treee475849a39c419c60de31dad0db34995564cf68f /ext/Makefile.am
parent7fa54d624d340459672624c1764835c01fcaddf4 (diff)
Add musepack decoder.
Original commit message from CVS: * configure.ac: * ext/Makefile.am: * ext/musepack/Makefile.am: * ext/musepack/gstmusepackdec.cpp: * ext/musepack/gstmusepackdec.h: * ext/musepack/gstmusepackreader.cpp: * ext/musepack/gstmusepackreader.h: Add musepack decoder. * ext/faad/gstfaad.c: (gst_faad_base_init): Make pad templates static. * gst/typefind/gsttypefindfunctions.c: (mp3_type_find), (plugin_init): Add musepack typefinder, make mp3 typefinding work halfway stream, which doesn't actually work yet because id3demux doesn't implement _get_length().
Diffstat (limited to 'ext/Makefile.am')
-rw-r--r--ext/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/ext/Makefile.am b/ext/Makefile.am
index cd9c5ac3..311a3209 100644
--- a/ext/Makefile.am
+++ b/ext/Makefile.am
@@ -238,6 +238,12 @@ endif
#MAS_DIR=
#endif
+if USE_MUSEPACK
+MUSEPACK_DIR=musepack
+else
+MUSEPACK_DIR=
+endif
+
if USE_MUSICBRAINZ
MUSICBRAINZ_DIR=musicbrainz
else
@@ -399,6 +405,7 @@ SUBDIRS=\
$(MPEG2DEC_DIR) \
$(MPEG2ENC_DIR) \
$(MPLEX_DIR) \
+ $(MUSEPACK_DIR) \
$(MUSICBRAINZ_DIR) \
$(OGG_DIR) \
$(PANGO_DIR) \
@@ -458,6 +465,7 @@ DIST_SUBDIRS=\
mpeg2dec \
mpeg2enc \
mplex \
+ musepack \
musicbrainz \
nas \
ogg \