summaryrefslogtreecommitdiffstats
path: root/ext/Makefile.am
diff options
context:
space:
mode:
authorWim Taymans <wim.taymans@gmail.com>2006-02-15 12:17:28 +0000
committerWim Taymans <wim.taymans@gmail.com>2006-02-15 12:17:28 +0000
commit5e5386b43004e38fe50b4d51d90f945b2332bc9e (patch)
treeb9646750ab01abdbe27c94895f6303282b5e5ffb /ext/Makefile.am
parent7531337e949072e2e5ee6659e91962bb1835956b (diff)
Add HAL sound device wrapper plugins. Closes #329106
Original commit message from CVS: * configure.ac: * docs/plugins/Makefile.am: * docs/plugins/gst-plugins-good-plugins-docs.sgml: * docs/plugins/gst-plugins-good-plugins-sections.txt: * docs/plugins/gst-plugins-good-plugins.hierarchy: * ext/Makefile.am: * ext/hal/Makefile.am: * ext/hal/gsthalaudiosink.c: (gst_hal_audio_sink_base_init), (gst_hal_audio_sink_class_init), (gst_hal_audio_sink_reset), (gst_hal_audio_sink_init), (gst_hal_audio_sink_dispose), (do_toggle_element), (gst_hal_audio_sink_set_property), (gst_hal_audio_sink_get_property), (gst_hal_audio_sink_change_state): * ext/hal/gsthalaudiosink.h: * ext/hal/gsthalaudiosrc.c: (gst_hal_audio_src_base_init), (gst_hal_audio_src_class_init), (gst_hal_audio_src_reset), (gst_hal_audio_src_init), (gst_hal_audio_src_dispose), (do_toggle_element), (gst_hal_audio_src_set_property), (gst_hal_audio_src_get_property), (gst_hal_audio_src_change_state): * ext/hal/gsthalaudiosrc.h: * ext/hal/gsthalelements.c: (plugin_init): * ext/hal/gsthalelements.h: * ext/hal/hal.c: (gst_hal_get_string), (gst_hal_render_bin_from_udi), (gst_hal_get_audio_sink), (gst_hal_get_audio_src): * ext/hal/hal.h: Add HAL sound device wrapper plugins. Closes #329106
Diffstat (limited to 'ext/Makefile.am')
-rw-r--r--ext/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/ext/Makefile.am b/ext/Makefile.am
index cdc854f6..438c8d7f 100644
--- a/ext/Makefile.am
+++ b/ext/Makefile.am
@@ -40,6 +40,12 @@ endif
GDK_PIXBUF_DIR =
# endif
+if USE_HAL
+HAL_DIR = hal
+else
+HAL_DIR =
+endif
+
if USE_JPEG
JPEG_DIR = jpeg
else
@@ -109,6 +115,7 @@ SUBDIRS = \
$(FLAC_DIR) \
$(GCONF_DIR) \
$(GDK_PIXBUF_DIR) \
+ $(HAL_DIR) \
$(JPEG_DIR) \
$(LADSPA_DIR) \
$(LIBCACA_DIR) \
@@ -127,6 +134,7 @@ DIST_SUBDIRS = \
esd \
flac \
gconf \
+ hal \
jpeg \
ladspa \
libcaca \