summaryrefslogtreecommitdiffstats
path: root/ext/Makefile.am
diff options
context:
space:
mode:
authorRonald S. Bultje <rbultje@ronald.bitfreak.net>2005-07-20 10:07:10 +0000
committerRonald S. Bultje <rbultje@ronald.bitfreak.net>2005-07-20 10:07:10 +0000
commit961178077ee2b11f8ccfca69b97527da6ac2750d (patch)
treefd4373131ebef374b1af0e013d4b83c4ec650836 /ext/Makefile.am
parentbef986dba1998d669af2d95034b4cfd9e3bd1caa (diff)
Port auto/gconfsinks to 0.9. They actually appear to work here in
Original commit message from CVS: * configure.ac: * ext/Makefile.am: * ext/gconf/Makefile.am: * ext/gconf/gconf.c: (gst_bin_find_unconnected_pad), (gst_gconf_render_bin_from_description), (gst_gconf_get_default_video_sink): * ext/gconf/gstgconfaudiosink.c: (gst_gconf_audio_sink_base_init), (gst_gconf_audio_sink_class_init), (gst_gconf_audio_sink_dispose), (cb_toggle_element), (gst_gconf_audio_sink_change_state): * ext/gconf/gstgconfelements.h: * ext/gconf/gstgconfvideosink.c: (gst_gconf_video_sink_base_init), (gst_gconf_video_sink_class_init), (gst_gconf_video_sink_dispose), (cb_toggle_element), (gst_gconf_video_sink_change_state): * gst/autodetect/gstautoaudiosink.c: (gst_auto_audio_sink_base_init), (gst_auto_audio_sink_class_init), (gst_auto_audio_sink_detect), (gst_auto_audio_sink_change_state): * gst/autodetect/gstautovideosink.c: (gst_auto_video_sink_base_init), (gst_auto_video_sink_class_init), (gst_auto_video_sink_find_best), (gst_auto_video_sink_detect): Port auto/gconfsinks to 0.9. They actually appear to work here in Totem as well, making them actually useful.
Diffstat (limited to 'ext/Makefile.am')
-rw-r--r--ext/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/ext/Makefile.am b/ext/Makefile.am
index 13e48435..0bfa012c 100644
--- a/ext/Makefile.am
+++ b/ext/Makefile.am
@@ -124,6 +124,12 @@ endif
FLAC_DIR=
# endif
+if USE_GCONF
+GCONF_DIR=gconf
+else
+GCONF_DIR=
+endif
+
# if USE_GDK_PIXBUF
# GDK_PIXBUF_DIR=gdk_pixbuf
# else
@@ -393,6 +399,7 @@ SUBDIRS=\
$(FAAC_DIR) \
$(FAAD_DIR) \
$(FLAC_DIR) \
+ $(GCONF_DIR) \
$(GDK_PIXBUF_DIR) \
$(GNOMEVFS_DIR) \
$(GSM_DIR) \
@@ -434,6 +441,7 @@ SUBDIRS=\
DIST_SUBDIRS=\
mad \
+ gconf \
shout2 \
sidplay \
aalib \