summaryrefslogtreecommitdiffstats
path: root/ext/gconf/Makefile.am
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2005-07-20 09:55:36 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2005-07-20 09:55:36 +0000
commit3cce8bfa667613395d581f81e1e2d6da2f60aa34 (patch)
treed864bd9ee2ac2a7f64fa9259215b879ca2979b2a /ext/gconf/Makefile.am
parent7e0d2491d1e41134d9296137d1b486a023b745a6 (diff)
put in gconf sinks
Original commit message from CVS: put in gconf sinks
Diffstat (limited to 'ext/gconf/Makefile.am')
-rw-r--r--ext/gconf/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/ext/gconf/Makefile.am b/ext/gconf/Makefile.am
new file mode 100644
index 00000000..7f0052fb
--- /dev/null
+++ b/ext/gconf/Makefile.am
@@ -0,0 +1,17 @@
+plugin_LTLIBRARIES = libgstgconfelements.la
+
+libgstgconfelements_la_SOURCES = \
+ gstgconfaudiosink.c \
+ gstgconfelements.c \
+ gstgconfvideosink.c
+
+DIR_CFLAGS = -DGST_GCONF_DIR=\"/system/gstreamer/@GST_MAJORMINOR@\"
+libgstgconfelements_la_CFLAGS = $(GST_CFLAGS) $(GCONF_CFLAGS) $(DIR_CFLAGS)
+libgstgconfelements_la_LIBADD = $(GCONF_LIBS) \
+ $(top_builddir)/gst-libs/gst/gconf/libgstgconf-@GST_MAJORMINOR@.la
+libgstgconfelements_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+
+noinst_HEADERS = \
+ gstgconfaudiosink.h \
+ gstgconfelements.h \
+ gstgconfvideosink.h