summaryrefslogtreecommitdiffstats
path: root/ext/gconf/Makefile.am
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.net>2006-01-06 16:28:30 +0000
committerTim-Philipp Müller <tim@centricular.net>2006-01-06 16:28:30 +0000
commitcc627c9c818eed1ebac140036e4a3fe767acbe18 (patch)
tree2c180b6a6a9459caeefe654d1ee9a039902f1173 /ext/gconf/Makefile.am
parentc6b9d19c3100c3600243526986f9adb205bc55e1 (diff)
ext/gconf/: Add new gconfaudiosrc and gconfvideosrc elements (needed for gnome-sound-recorder).
Original commit message from CVS: * ext/gconf/Makefile.am: * ext/gconf/gstgconfaudiosrc.c: (gst_gconf_audio_src_base_init), (gst_gconf_audio_src_class_init), (gst_gconf_audio_src_reset), (gst_gconf_audio_src_init), (gst_gconf_audio_src_dispose), (do_toggle_element), (cb_toggle_element), (gst_gconf_audio_src_change_state): * ext/gconf/gstgconfaudiosrc.h: * ext/gconf/gstgconfelements.c: (plugin_init): * ext/gconf/gstgconfvideosrc.c: (gst_gconf_video_src_base_init), (gst_gconf_video_src_class_init), (gst_gconf_video_src_reset), (gst_gconf_video_src_init), (gst_gconf_video_src_dispose), (do_toggle_element), (cb_toggle_element), (gst_gconf_video_src_change_state): * ext/gconf/gstgconfvideosrc.h: Add new gconfaudiosrc and gconfvideosrc elements (needed for gnome-sound-recorder).
Diffstat (limited to 'ext/gconf/Makefile.am')
-rw-r--r--ext/gconf/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/ext/gconf/Makefile.am b/ext/gconf/Makefile.am
index 688d38a0..942aa283 100644
--- a/ext/gconf/Makefile.am
+++ b/ext/gconf/Makefile.am
@@ -2,8 +2,10 @@ plugin_LTLIBRARIES = libgstgconfelements.la
libgstgconfelements_la_SOURCES = \
gstgconfaudiosink.c \
+ gstgconfaudiosrc.c \
gstgconfelements.c \
gstgconfvideosink.c \
+ gstgconfvideosrc.c \
gconf.c
DIR_CFLAGS = -DGST_GCONF_DIR=\"/system/gstreamer/@GST_MAJORMINOR@\"
@@ -13,6 +15,8 @@ libgstgconfelements_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
noinst_HEADERS = \
gstgconfaudiosink.h \
+ gstgconfaudiosrc.h \
gstgconfelements.h \
gstgconfvideosink.h \
+ gstgconfvideosrc.h \
gconf.h