summaryrefslogtreecommitdiffstats
path: root/ext/gdk_pixbuf/Makefile.am
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.net>2008-04-03 22:50:48 +0000
committerTim-Philipp Müller <tim@centricular.net>2008-04-03 22:50:48 +0000
commit27f764087c1222cd0ae1631bdb58098af2ab0e18 (patch)
tree4ebc20d0db3396825dcbf3fccbe92519c6efe7ec /ext/gdk_pixbuf/Makefile.am
parentde38811fbe700207e3b446bc0ebb7e0e319003b4 (diff)
ext/gdk_pixbuf/: Add gdkpixbufsink element for easy snapshotting (#525946).
Original commit message from CVS: * ext/gdk_pixbuf/Makefile.am: * ext/gdk_pixbuf/gstgdkpixbuf.c: (plugin_init): * ext/gdk_pixbuf/gstgdkpixbufsink.c: (gst_gdk_pixbuf_sink_base_init), (gst_gdk_pixbuf_sink_class_init), (gst_gdk_pixbuf_sink_init), (gst_gdk_pixbuf_sink_start), (gst_gdk_pixbuf_sink_stop), (gst_gdk_pixbuf_sink_set_caps), (gst_gdk_pixbuf_sink_pixbuf_destroy_notify), (gst_gdk_pixbuf_sink_get_pixbuf_from_buffer), (gst_gdk_pixbuf_sink_handle_buffer), (gst_gdk_pixbuf_sink_preroll), (gst_gdk_pixbuf_sink_render), (gst_gdk_pixbuf_sink_set_property), (gst_gdk_pixbuf_sink_get_property): * ext/gdk_pixbuf/gstgdkpixbufsink.h: Add gdkpixbufsink element for easy snapshotting (#525946).
Diffstat (limited to 'ext/gdk_pixbuf/Makefile.am')
-rw-r--r--ext/gdk_pixbuf/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/ext/gdk_pixbuf/Makefile.am b/ext/gdk_pixbuf/Makefile.am
index 316ca4e5..63efd461 100644
--- a/ext/gdk_pixbuf/Makefile.am
+++ b/ext/gdk_pixbuf/Makefile.am
@@ -1,14 +1,18 @@
plugin_LTLIBRARIES = libgstgdkpixbuf.la
-libgstgdkpixbuf_la_SOURCES = gstgdkpixbuf.c pixbufscale.c
+libgstgdkpixbuf_la_SOURCES = gstgdkpixbuf.c gstgdkpixbufsink.c pixbufscale.c
libgstgdkpixbuf_la_CFLAGS = \
$(GST_PLUGINS_BASE_CFLAGS) \
$(GST_BASE_CFLAGS) \
$(GST_CFLAGS) $(GTK_CFLAGS)
-libgstgdkpixbuf_la_LIBADD = $(GST_BASE_LIBS) $(GST_LIBS) $(GTK_LIBS)
+libgstgdkpixbuf_la_LIBADD = \
+ $(GST_PLUGINS_BASE_LIBS) -lgstvideo-$(GST_MAJORMINOR) \
+ $(GST_BASE_LIBS) \
+ $(GST_LIBS) $(GTK_LIBS)
libgstgdkpixbuf_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
noinst_HEADERS = \
gstgdkpixbuf.h \
+ gstgdkpixbufsink.h \
pixbufscale.h \
gstgdkanimation.h