summaryrefslogtreecommitdiffstats
path: root/ext/libpng/Makefile.am
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2002-11-18 22:29:38 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2002-11-18 22:29:38 +0000
commit1c4686af940a6191c284c93b75968a24eb081fbc (patch)
treec855da10c37a43f999ac5921bbad28fefd3be8b6 /ext/libpng/Makefile.am
parent5ed59e18ed6bca07f66c7820694eb0a3f00b42e5 (diff)
putting in apoc's png encoder, needs some cleanup
Original commit message from CVS: putting in apoc's png encoder, needs some cleanup
Diffstat (limited to 'ext/libpng/Makefile.am')
-rw-r--r--ext/libpng/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/ext/libpng/Makefile.am b/ext/libpng/Makefile.am
new file mode 100644
index 00000000..a65008d9
--- /dev/null
+++ b/ext/libpng/Makefile.am
@@ -0,0 +1,11 @@
+plugindir = $(libdir)/gst
+
+plugin_LTLIBRARIES = libgstpng.la
+
+libgstpng_la_SOURCES = gstpng.c gstpngenc.c
+libgstpng_la_CFLAGS = $(GST_CFLAGS)
+libgstpng_la_LIBADD = $(GST_LIBS) $(LIBPNG_LIBS)
+libgstpng_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+
+noinst_HEADERS = gstpng.h
+