summaryrefslogtreecommitdiffstats
path: root/ext/libpng/Makefile.am
diff options
context:
space:
mode:
authorWim Taymans <wim.taymans@gmail.com>2004-07-16 10:56:31 +0000
committerWim Taymans <wim.taymans@gmail.com>2004-07-16 10:56:31 +0000
commite4908795d7a54fc29b42eccd621fc63c15f5eff4 (patch)
tree5d97d3147c14bd8ba3688a48105b4257963f2332 /ext/libpng/Makefile.am
parentdfb55453e44df4e7b45d82c55fe1fe78fa72c773 (diff)
ext/libpng/: Added png decoder.
Original commit message from CVS: * ext/libpng/Makefile.am: * ext/libpng/gstpng.c: (plugin_init): * ext/libpng/gstpngdec.c: (user_error_fn), (user_warning_fn), (gst_pngdec_get_type), (gst_pngdec_base_init), (gst_pngdec_class_init), (gst_pngdec_sinklink), (gst_pngdec_init), (gst_pngdec_src_getcaps), (user_read_data), (gst_pngdec_chain): * ext/libpng/gstpngdec.h: Added png decoder.
Diffstat (limited to 'ext/libpng/Makefile.am')
-rw-r--r--ext/libpng/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/ext/libpng/Makefile.am b/ext/libpng/Makefile.am
index 868ec54d..0d745147 100644
--- a/ext/libpng/Makefile.am
+++ b/ext/libpng/Makefile.am
@@ -1,9 +1,9 @@
plugin_LTLIBRARIES = libgstpng.la
-libgstpng_la_SOURCES = gstpng.c gstpngenc.c
+libgstpng_la_SOURCES = gstpng.c gstpngdec.c gstpngenc.c
libgstpng_la_CFLAGS = $(GST_CFLAGS)
libgstpng_la_LIBADD = $(GST_LIBS) $(LIBPNG_LIBS)
libgstpng_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
-noinst_HEADERS = gstpngenc.h
+noinst_HEADERS = gstpngdec.h gstpngenc.h