summaryrefslogtreecommitdiffstats
path: root/ext/raw1394/Makefile.am
diff options
context:
space:
mode:
authorZaheer Abbas Merali <zaheerabbas@merali.org>2006-05-31 10:31:23 +0000
committerZaheer Abbas Merali <zaheerabbas@merali.org>2006-05-31 10:31:23 +0000
commit1710bee58ad9eecda6c27db3bb7deec9cb13c5c7 (patch)
treef6cf92c9555bdb5a2325e198484cd4e6c9bd3073 /ext/raw1394/Makefile.am
parentc6919694d0bdc28a82a20ab21d59c7dfb9c38b4d (diff)
configure.ac: Detect libiec61883 and set necessary CFLAGS and LIBS for dv1394.
Original commit message from CVS: 2006-05-31 Zaheer Abbas Merali <zaheerabbas at merali dot org> * configure.ac: Detect libiec61883 and set necessary CFLAGS and LIBS for dv1394. * ext/raw1394/Makefile.am: Add CFLAGS. * ext/raw1394/gstdv1394src.c: (gst_dv1394src_iec61883_receive), New method, to receive using libiec61883. (gst_dv1394src_iso_receive), #ifdef'd out if libiec61883 is present. (gst_dv1394src_bus_reset), Get userdata correctly if using libiec61883. (gst_dv1394src_create), When using libiec61883, only poll one fd and no need to read. (gst_dv1394src_discover_avc_node), Replace g_warnings. (gst_dv1394src_start), Create new handle when we know which dv port. More reliable than setting port on an existing handle. Initialise libiec61883. (gst_dv1394src_stop): If using libiec61883, then cleanup its handle properly. * ext/raw1394/gstdv1394src.h: Add libiec61883 handle.
Diffstat (limited to 'ext/raw1394/Makefile.am')
-rw-r--r--ext/raw1394/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/ext/raw1394/Makefile.am b/ext/raw1394/Makefile.am
index 73082d27..57749084 100644
--- a/ext/raw1394/Makefile.am
+++ b/ext/raw1394/Makefile.am
@@ -1,7 +1,7 @@
plugin_LTLIBRARIES = libgst1394.la
libgst1394_la_SOURCES = gst1394.c gstdv1394src.c
-libgst1394_la_CFLAGS = $(GST_CFLAGS)
+libgst1394_la_CFLAGS = $(GST_CFLAGS) $(DV1394_CFLAGS)
libgst1394_la_LIBADD = $(GST_BASE_LIBS) $(DV1394_LIBS)
libgst1394_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)