summaryrefslogtreecommitdiffstats
path: root/ext/raw1394/Makefile.am
diff options
context:
space:
mode:
authorJulien Puydt <julien.puydt@laposte.net>2007-11-14 19:10:37 +0000
committerTim-Philipp Müller <tim@centricular.net>2007-11-14 19:10:37 +0000
commitf691a70d69d3e816d370e82cf08de0fd7c7df0b6 (patch)
treef2fbb05d30141f4d3fc8524fb6fb556496104d0c /ext/raw1394/Makefile.am
parent012a21be129d95f53470eec329fdba05940074a7 (diff)
ext/raw1394/: Implement GstPropertyProbe interface and add "device-name" property, so applications can use this to pr...
Original commit message from CVS: Patch by: Julien Puydt <julien dot puydt at laposte net> * ext/raw1394/Makefile.am: * ext/raw1394/gst1394probe.c: (gst_1394_get_guid_array), (gst_1394_property_probe_get_properties), (gst_1394_property_probe_probe_property), (gst_1394_property_probe_needs_probe), (gst_1394_property_probe_get_values), (gst_1394_property_probe_interface_init), (gst_1394_type_add_property_probe_interface): * ext/raw1394/gst1394probe.h: (GST_1394_PROBE_H): * ext/raw1394/gstdv1394src.c: (_do_init), (gst_dv1394src_class_init), (gst_dv1394src_init), (gst_dv1394src_dispose), (gst_dv1394src_set_property), (gst_dv1394src_get_property), (gst_dv1394src_discover_avc_node), (gst_dv1394src_query), (gst_dv1394src_update_device_name): * ext/raw1394/gstdv1394src.h: Implement GstPropertyProbe interface and add "device-name" property, so applications can use this to probe for available devices in the same way they can already with v4lsrc and v4l2src (however horrible this property probe interface may be). Fixes #358841.
Diffstat (limited to 'ext/raw1394/Makefile.am')
-rw-r--r--ext/raw1394/Makefile.am16
1 files changed, 12 insertions, 4 deletions
diff --git a/ext/raw1394/Makefile.am b/ext/raw1394/Makefile.am
index 57749084..8c644d33 100644
--- a/ext/raw1394/Makefile.am
+++ b/ext/raw1394/Makefile.am
@@ -1,8 +1,16 @@
plugin_LTLIBRARIES = libgst1394.la
-libgst1394_la_SOURCES = gst1394.c gstdv1394src.c
-libgst1394_la_CFLAGS = $(GST_CFLAGS) $(DV1394_CFLAGS)
-libgst1394_la_LIBADD = $(GST_BASE_LIBS) $(DV1394_LIBS)
+libgst1394_la_SOURCES = gst1394.c gst1394probe.c gstdv1394src.c
+libgst1394_la_CFLAGS = \
+ $(GST_PLUGINS_BASE_CFLAGS) \
+ $(GST_BASE_CFLAGS) \
+ $(GST_CFLAGS) \
+ $(DV1394_CFLAGS)
+libgst1394_la_LIBADD = \
+ $(GST_PLUGINS_BASE_LIBS) -lgstinterfaces-$(GST_MAJORMINOR) \
+ $(GST_BASE_LIBS) \
+ $(GST_LIBS) \
+ $(DV1394_LIBS)
libgst1394_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
-noinst_HEADERS = gstdv1394src.h
+noinst_HEADERS = gstdv1394src.h gst1394probe.h