summaryrefslogtreecommitdiffstats
path: root/gconf/Makefile.am
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2004-02-23 22:31:48 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2004-02-23 22:31:48 +0000
commit24204a788425e93a512b5cf7688184875f665d6e (patch)
treeb27b55309701996043c173be352532bbc6e19df1 /gconf/Makefile.am
parenta9e7cd5c7b1c2529c3a497a33143bd18054dbe11 (diff)
versioning gstreamer schemas and install location
Original commit message from CVS: versioning gstreamer schemas and install location
Diffstat (limited to 'gconf/Makefile.am')
-rw-r--r--gconf/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/gconf/Makefile.am b/gconf/Makefile.am
index b3ca1fad..8fa37fbc 100644
--- a/gconf/Makefile.am
+++ b/gconf/Makefile.am
@@ -1,5 +1,8 @@
schemadir = @GCONF_SCHEMA_FILE_DIR@
-schema_DATA = gstreamer.schemas
+schema_DATA = gstreamer-@GST_MAJORMINOR@.schemas
+
+gstreamer-@GST_MAJORMINOR@.schemas: gstreamer.schemas
+ cp $< $@
install-data-local:
@GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) \
@@ -10,4 +13,5 @@ install-data-local:
echo "*****************************************************";)
@true
-EXTRA_DIST = gstreamer.schemas
+CLEANFILES = $(schema_DATA)
+EXTRA_DIST = $(schema_DATA)