summaryrefslogtreecommitdiffstats
path: root/gst/alpha/Makefile.am
diff options
context:
space:
mode:
authorJan Schmidt <thaytan@mad.scientist.com>2008-01-31 00:00:23 +0000
committerJan Schmidt <thaytan@mad.scientist.com>2008-01-31 00:00:23 +0000
commite315541000ece43370fd884d19660d9ae7fecfb3 (patch)
tree6d4245965ff89789745c3f9c55f41da6b68a4194 /gst/alpha/Makefile.am
parent0465f9b72fd1b73f0df947a97536fb6d2be73f6f (diff)
gst/alpha/: Re-write the 'alpha' plugin to be BaseTransform based, simplifying some stuff, and making buffer-alloc an...
Original commit message from CVS: * gst/alpha/Makefile.am: * gst/alpha/gstalpha.c: Re-write the 'alpha' plugin to be BaseTransform based, simplifying some stuff, and making buffer-alloc and resizing work automatically. No longer crashes on odd frame widths and heights, although there seems to be a disagreement with ffmpegcolorspace about what size an AYUV frame with odd height should be.
Diffstat (limited to 'gst/alpha/Makefile.am')
-rw-r--r--gst/alpha/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/gst/alpha/Makefile.am b/gst/alpha/Makefile.am
index 1ae03a41..98f81167 100644
--- a/gst/alpha/Makefile.am
+++ b/gst/alpha/Makefile.am
@@ -3,7 +3,8 @@ plugin_LTLIBRARIES = libgstalpha.la libgstalphacolor.la
libgstalpha_la_SOURCES = gstalpha.c
libgstalpha_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) \
$(GST_BASE_CFLAGS) $(GST_CFLAGS) $(GST_CONTROLLER_CFLAGS)
-libgstalpha_la_LIBADD = $(GST_LIBS) $(LIBM) $(GST_CONTROLLER_LIBS)
+libgstalpha_la_LIBADD = $(GST_PLUGINS_BASE_LIBS) -lgstvideo-$(GST_MAJORMINOR) \
+ $(GST_LIBS) $(LIBM) $(GST_CONTROLLER_LIBS)
libgstalpha_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
libgstalphacolor_la_SOURCES = gstalphacolor.c