summaryrefslogtreecommitdiffstats
path: root/gst/cutter/Makefile.am
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2005-11-21 19:50:25 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2005-11-21 19:50:25 +0000
commit15c52996c2563871b3d3340c37f5a7e009cd01e2 (patch)
treecec0bbb7f821625255cfa1bfe89882ccaf8b1a6b /gst/cutter/Makefile.am
parent3cbd39e022c47cabd8dca1657ea79759bc6b4615 (diff)
port cutter
Original commit message from CVS: * configure.ac: * gst/cutter/Makefile.am: * gst/cutter/gstcutter.c: (gst_cutter_class_init), (gst_cutter_init), (gst_cutter_message_new), (gst_cutter_chain), (gst_cutter_set_property), (gst_cutter_get_property), (plugin_init), (gst_cutter_get_caps): port cutter * gst/level/gstlevel.c: fix up plugin details
Diffstat (limited to 'gst/cutter/Makefile.am')
-rw-r--r--gst/cutter/Makefile.am5
1 files changed, 2 insertions, 3 deletions
diff --git a/gst/cutter/Makefile.am b/gst/cutter/Makefile.am
index e88ef155..0d93b29d 100644
--- a/gst/cutter/Makefile.am
+++ b/gst/cutter/Makefile.am
@@ -1,9 +1,8 @@
-
plugin_LTLIBRARIES = libgstcutter.la
libgstcutter_la_SOURCES = gstcutter.c
-libgstcutter_la_CFLAGS = $(GST_CFLAGS)
-libgstcutter_la_LIBADD = $(GST_LIBS)
+libgstcutter_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_BASE_CFLAGS) $(GST_CFLAGS)
+libgstcutter_la_LIBADD = $(GST_PLUGINS_BASE_LIBS) -lgstaudio-$(GST_MAJORMINOR) $(GST_BASE_LIBS)
libgstcutter_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
noinst_HEADERS = gstcutter.h filter.func