summaryrefslogtreecommitdiffstats
path: root/gst/goom2k1/Makefile.am
diff options
context:
space:
mode:
authorJan Schmidt <thaytan@mad.scientist.com>2008-02-23 15:02:15 +0000
committerJan Schmidt <thaytan@mad.scientist.com>2008-02-23 15:02:15 +0000
commita681a56b1d4a8b9f6bb30b6ce855a97fa0ba526f (patch)
treeec076ab3c023b03f8ac8ba72a0363b1dde90fb96 /gst/goom2k1/Makefile.am
parent954187812fe276dbf92ddb3af849961e936ab5dc (diff)
gst/goom2k1/: Rename the installed library, and don't register the same
Original commit message from CVS: * gst/goom2k1/Makefile.am: * gst/goom2k1/gstgoom.c: Rename the installed library, and don't register the same GType name as the new goom.
Diffstat (limited to 'gst/goom2k1/Makefile.am')
-rw-r--r--gst/goom2k1/Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/gst/goom2k1/Makefile.am b/gst/goom2k1/Makefile.am
index 4f4abb76..4db8d00e 100644
--- a/gst/goom2k1/Makefile.am
+++ b/gst/goom2k1/Makefile.am
@@ -1,14 +1,14 @@
-plugin_LTLIBRARIES = libgstgoom.la
+plugin_LTLIBRARIES = libgstgoom2k1.la
GOOM_FILTER_FILES = filters.c
GOOM_FILTER_CFLAGS = -UMMX -UUSE_ASM
noinst_HEADERS = gstgoom.h filters.h goom_core.h goom_tools.h graphic.h lines.h
-libgstgoom_la_SOURCES = gstgoom.c goom_core.c $(GOOM_FILTER_FILES) graphic.c lines.c
+libgstgoom2k1_la_SOURCES = gstgoom.c goom_core.c $(GOOM_FILTER_FILES) graphic.c lines.c
-libgstgoom_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_BASE_CFLAGS) $(GST_CFLAGS) $(GOOM_FILTER_CFLAGS)
-libgstgoom_la_LIBADD = $(GST_BASE_LIBS) $(GST_LIBS) $(LIBM)
-libgstgoom_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+libgstgoom2k1_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_BASE_CFLAGS) $(GST_CFLAGS) $(GOOM_FILTER_CFLAGS)
+libgstgoom2k1_la_LIBADD = $(GST_BASE_LIBS) $(GST_LIBS) $(LIBM)
+libgstgoom2k1_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
EXTRA_DIST = filters.c