summaryrefslogtreecommitdiffstats
path: root/gst/id3demux/Makefile.am
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.net>2006-03-04 20:11:35 +0000
committerTim-Philipp Müller <tim@centricular.net>2006-03-04 20:11:35 +0000
commit5a7a0b082465630f53800c52b87aba95ea6892b0 (patch)
treeb32475e9291e7f63e52f44352d64cbfbd4585ef8 /gst/id3demux/Makefile.am
parentbc0abfc8d1d251c33b4f044c48a18658fe56c976 (diff)
gst/id3demux/: Use new typefind helper functions here as well, and do typefinding in pull-mode if upstream supports t...
Original commit message from CVS: * gst/id3demux/Makefile.am: * gst/id3demux/gstid3demux.c: (gst_id3demux_add_srcpad), (gst_id3demux_chain), (gst_id3demux_sink_activate): Use new typefind helper functions here as well, and do typefinding in pull-mode if upstream supports that.
Diffstat (limited to 'gst/id3demux/Makefile.am')
-rw-r--r--gst/id3demux/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/gst/id3demux/Makefile.am b/gst/id3demux/Makefile.am
index afb79c31..7e83001e 100644
--- a/gst/id3demux/Makefile.am
+++ b/gst/id3demux/Makefile.am
@@ -1,8 +1,8 @@
plugin_LTLIBRARIES = libgstid3demux.la
libgstid3demux_la_SOURCES = gstid3demux.c id3tags.c id3v2frames.c
-libgstid3demux_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_CFLAGS)
-libgstid3demux_la_LIBADD = $(GST_PLUGINS_BASE_LIBS) -lgsttag-@GST_MAJORMINOR@ $(ZLIB_LIBS)
+libgstid3demux_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_BASE_CFLAGS) $(GST_CFLAGS)
+libgstid3demux_la_LIBADD = $(GST_PLUGINS_BASE_LIBS) -lgsttag-@GST_MAJORMINOR@ $(GST_BASE_LIBS) $(ZLIB_LIBS)
libgstid3demux_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
noinst_HEADERS = gstid3demux.h id3tags.h