summaryrefslogtreecommitdiffstats
path: root/gst/interleave/Makefile.am
diff options
context:
space:
mode:
authorAndy Wingo <wingo@pobox.com>2007-01-07 22:03:54 +0000
committerAndy Wingo <wingo@pobox.com>2007-01-07 22:03:54 +0000
commit12359919d3932f49a04382e72be855df53fa1800 (patch)
tree56bfe273b060867bdfa65c91850c36403a778b83 /gst/interleave/Makefile.am
parent8d2ac1002ccf11a8ec0a56c4ef3a3bdbf74523b4 (diff)
New elements interleave and deinterleave, implement channel interleaving and deinterleaving.
Original commit message from CVS: 2007-01-07 Andy Wingo <wingo@pobox.com> * configure.ac: * gst/interleave/Makefile.am: * gst/interleave/plugin.h: * gst/interleave/plugin.c: * gst/interleave/interleave.c: * gst/interleave/deinterleave.c: New elements interleave and deinterleave, implement channel interleaving and deinterleaving. The interleaver can operate in pull or push mode but the deinterleaver is more like a demuxer and can only operate in push mode.
Diffstat (limited to 'gst/interleave/Makefile.am')
-rw-r--r--gst/interleave/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/gst/interleave/Makefile.am b/gst/interleave/Makefile.am
new file mode 100644
index 00000000..9a09cdbc
--- /dev/null
+++ b/gst/interleave/Makefile.am
@@ -0,0 +1,9 @@
+
+plugin_LTLIBRARIES = libgstinterleave.la
+
+libgstinterleave_la_SOURCES = plugin.c interleave.c deinterleave.c
+libgstinterleave_la_CFLAGS = $(GST_CFLAGS)
+libgstinterleave_la_LIBADD = $(GST_LIBS)
+libgstinterleave_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+
+noinst_HEADERS = plugin.h