summaryrefslogtreecommitdiffstats
path: root/gst/interleave/Makefile.am
diff options
context:
space:
mode:
authorSebastian Dröge <slomo@circular-chaos.org>2008-05-14 07:32:44 +0000
committerSebastian Dröge <slomo@circular-chaos.org>2008-05-14 07:32:44 +0000
commitafe112e12179246bb32e170f13c379ade4d1389c (patch)
treed9a4bb2399b679c6ea7e9915b7cfcc3955ed4653 /gst/interleave/Makefile.am
parent94414c07a67cc0b9112651384bf516d74aef9551 (diff)
gst/interleave/: Split definitions into separate header files for better documentation generation.
Original commit message from CVS: * gst/interleave/Makefile.am: * gst/interleave/deinterleave.h: * gst/interleave/interleave.h: * gst/interleave/plugin.h: Split definitions into separate header files for better documentation generation. * gst/interleave/deinterleave.c: (gst_deinterleave_base_init), (gst_deinterleave_class_init), (gst_deinterleave_sink_setcaps), (gst_deinterleave_process): Don't use alloca, allow caps changes as long as the number of channels does not change, don't use g_warning, return NOT_NEGOTIATED as early as possible and some other cleanup. * gst/interleave/interleave.c: (gst_interleave_base_init), (gst_interleave_class_init): Do some random cleanup. * tests/check/Makefile.am: * tests/check/elements/deinterleave.c: (GST_START_TEST), (deinterleave_chain_func), (deinterleave_pad_added), (deinterleave_suite): Add unit tests for the deinterleave element.
Diffstat (limited to 'gst/interleave/Makefile.am')
-rw-r--r--gst/interleave/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/gst/interleave/Makefile.am b/gst/interleave/Makefile.am
index 9a09cdbc..62e7f3e3 100644
--- a/gst/interleave/Makefile.am
+++ b/gst/interleave/Makefile.am
@@ -6,4 +6,4 @@ libgstinterleave_la_CFLAGS = $(GST_CFLAGS)
libgstinterleave_la_LIBADD = $(GST_LIBS)
libgstinterleave_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
-noinst_HEADERS = plugin.h
+noinst_HEADERS = plugin.h interleave.h deinterleave.h