summaryrefslogtreecommitdiffstats
path: root/gst/matroska/Makefile.am
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.net>2005-10-14 12:43:30 +0000
committerTim-Philipp Müller <tim@centricular.net>2005-10-14 12:43:30 +0000
commit22b9a5cd4310a0c4b4ab1508c0ac8fb6a951f061 (patch)
tree7425a287d6c908eb1acda5b99793ac69343d7a32 /gst/matroska/Makefile.am
parentfb495736bc531080df1a7874d7ef3b94679d25a9 (diff)
Port matroska muxer to 0.9 (#318847).
Original commit message from CVS: Reviewed by: Tim-Philipp Müller <tim at centricular dot net> * configure.ac: * gst/matroska/Makefile.am: * gst/matroska/ebml-ids.h: * gst/matroska/ebml-write.c: * gst/matroska/ebml-write.h: * gst/matroska/matroska-ids.h: * gst/matroska/matroska-mux.c: * gst/matroska/matroska-mux.h: * gst/matroska/matroska.c: (plugin_init): Port matroska muxer to 0.9 (#318847).
Diffstat (limited to 'gst/matroska/Makefile.am')
-rw-r--r--gst/matroska/Makefile.am17
1 files changed, 13 insertions, 4 deletions
diff --git a/gst/matroska/Makefile.am b/gst/matroska/Makefile.am
index 78f2c912..1dd6e0c7 100644
--- a/gst/matroska/Makefile.am
+++ b/gst/matroska/Makefile.am
@@ -1,12 +1,13 @@
plugin_LTLIBRARIES = libgstmatroska.la
libgstmatroska_la_SOURCES = \
- ebml-read.c \
ebml-write.c \
matroska.c \
- matroska-demux.c \
matroska-mux.c
+# ebml-read.c
+# matroska-demux.c
+
noinst_HEADERS = \
ebml-ids.h \
ebml-read.h \
@@ -15,6 +16,14 @@ noinst_HEADERS = \
matroska-ids.h \
matroska-mux.h
-libgstmatroska_la_CFLAGS = $(GST_CFLAGS)
-libgstmatroska_la_LIBADD = $(GST_LIBS)
+libgstmatroska_la_CFLAGS = \
+ $(GST_BASE_CFLAGS) \
+ $(GST_PLUGINS_BASE_CFLAGS) \
+ $(GST_CFLAGS) \
+ -I$(top_srcdir)/gst-libs
+libgstmatroska_la_LIBADD = \
+ $(GST_BASE_LIBS) \
+ $(GST_PLUGINS_BASE_LIBS) \
+ $(GST_LIBS) \
+ -lgstriff-@GST_MAJORMINOR@
libgstmatroska_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)