summaryrefslogtreecommitdiffstats
path: root/gst/matroska/Makefile.am
diff options
context:
space:
mode:
authorRonald S. Bultje <rbultje@ronald.bitfreak.net>2003-11-21 21:34:27 +0000
committerRonald S. Bultje <rbultje@ronald.bitfreak.net>2003-11-21 21:34:27 +0000
commit29e9ebcfda9cce9d72099d098d60bc7da0ea601a (patch)
treee84025a62eca39514a72abd5c7564d163a5326f1 /gst/matroska/Makefile.am
parente21d05a3008439620d90deaf8457336d1a44c58d (diff)
Add C-based local matroska/EBML plugin, remove libmatroska/libebml c++ one
Original commit message from CVS: Add C-based local matroska/EBML plugin, remove libmatroska/libebml c++ one
Diffstat (limited to 'gst/matroska/Makefile.am')
-rw-r--r--gst/matroska/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/gst/matroska/Makefile.am b/gst/matroska/Makefile.am
new file mode 100644
index 00000000..b0235d89
--- /dev/null
+++ b/gst/matroska/Makefile.am
@@ -0,0 +1,16 @@
+plugin_LTLIBRARIES = libgstmatroska.la
+
+libgstmatroska_la_SOURCES = \
+ ebml-read.c \
+ matroska.c \
+ matroska-demux.c
+
+noinst_HEADERS = \
+ ebml-ids.h \
+ ebml-read.h \
+ matroska-demux.h \
+ matroska-ids.h
+
+libgstmatroska_la_CFLAGS = $(GST_CFLAGS)
+libgstmatroska_la_LIBADD =
+libgstmatroska_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)