summaryrefslogtreecommitdiffstats
path: root/gst/matroska/Makefile.am
diff options
context:
space:
mode:
authorSebastian Dröge <slomo@circular-chaos.org>2008-03-08 04:40:32 +0000
committerSebastian Dröge <slomo@circular-chaos.org>2008-03-08 04:40:32 +0000
commit8342c0cc966644694c19de57434b17a821ecc9ae (patch)
treed59ced15fa4bf016b37206440c6c078e20f19e9f /gst/matroska/Makefile.am
parentc7296fe79a7e2f05d33f9ad5cb5b136150a1f710 (diff)
gst/matroska/ebml-ids.h: Add ID for EBML CRC32 elements.
Original commit message from CVS: * gst/matroska/ebml-ids.h: Add ID for EBML CRC32 elements. * gst/matroska/Makefile.am: * gst/matroska/ebml-read.c: (gst_ebml_finalize), (gst_ebml_read_class_init), (gst_ebml_read_peek_bytes), (gst_ebml_read_get_length), (_ext2dbl), (gst_ebml_read_float), (gst_ebml_read_header): Support reading 80bit floats, add finalize method to clean up in any case, support reading length/id elements with any length as long as it's smaller than our supported maximum, don't leak buffers if reading as much data as we wanted failed and some smaller cleanup.
Diffstat (limited to 'gst/matroska/Makefile.am')
-rw-r--r--gst/matroska/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/gst/matroska/Makefile.am b/gst/matroska/Makefile.am
index 21dbb514..1fa4f4bc 100644
--- a/gst/matroska/Makefile.am
+++ b/gst/matroska/Makefile.am
@@ -26,5 +26,6 @@ libgstmatroska_la_LIBADD = \
$(GST_PLUGINS_BASE_LIBS) \
$(GST_LIBS) \
-lgstriff-@GST_MAJORMINOR@ \
- $(ZLIB_LIBS)
+ $(ZLIB_LIBS) \
+ $(LIBM)
libgstmatroska_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)