summaryrefslogtreecommitdiffstats
path: root/gst/qtdemux/Makefile.am
diff options
context:
space:
mode:
authorEdward Hervey <bilboed@bilboed.com>2006-02-13 22:04:42 +0000
committerEdward Hervey <bilboed@bilboed.com>2006-02-13 22:04:42 +0000
commit7e2a049670be750218d37fe1b098f6f5afb53911 (patch)
tree27e30085bdd46cfa7319285558065c3af0e5afd4 /gst/qtdemux/Makefile.am
parent8d38cd443f4edd9554f676860cda7850da7ed246 (diff)
gst/qtdemux/: QtDemux can now work push-based.
Original commit message from CVS: * gst/qtdemux/Makefile.am: * gst/qtdemux/qtdemux.c: (gst_qtdemux_init), (gst_qtdemux_handle_sink_event), (gst_qtdemux_change_state), (extract_initial_length_and_fourcc), (gst_qtdemux_loop_state_header), (gst_qtdemux_loop_state_movie), (gst_qtdemux_loop_header), (next_entry_size), (gst_qtdemux_chain), (qtdemux_sink_activate), (qtdemux_sink_activate_pull), (qtdemux_sink_activate_push), (qtdemux_parse_trak): * gst/qtdemux/qtdemux.h: QtDemux can now work push-based. It still needs some love for seeking.
Diffstat (limited to 'gst/qtdemux/Makefile.am')
-rw-r--r--gst/qtdemux/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/gst/qtdemux/Makefile.am b/gst/qtdemux/Makefile.am
index 9c6a9659..f65f337e 100644
--- a/gst/qtdemux/Makefile.am
+++ b/gst/qtdemux/Makefile.am
@@ -2,7 +2,7 @@
plugin_LTLIBRARIES = libgstqtdemux.la
libgstqtdemux_la_CFLAGS = ${GST_CFLAGS}
-libgstqtdemux_la_LIBADD =
+libgstqtdemux_la_LIBADD = $(GST_BASE_LIBS)
libgstqtdemux_la_LDFLAGS = ${GST_PLUGIN_LDFLAGS}
libgstqtdemux_la_SOURCES = qtdemux.c