summaryrefslogtreecommitdiffstats
path: root/gst/qtdemux/Makefile.am
diff options
context:
space:
mode:
authorWim Taymans <wim.taymans@gmail.com>2007-01-12 17:16:51 +0000
committerWim Taymans <wim.taymans@gmail.com>2007-01-12 17:16:51 +0000
commitc7839a6aa79c4bf3622f682be2c69c9b28007aa5 (patch)
tree102e86cc80343b5aa45c1dd77440d7d85ba29a9b /gst/qtdemux/Makefile.am
parent9003c60563ec56b4956aa259ec250a127036023f (diff)
gst/qtdemux/: Add X-QT depayloader that will eventually share code with the demuxer.
Original commit message from CVS: * gst/qtdemux/Makefile.am: * gst/qtdemux/gstrtpxqtdepay.c: (gst_rtp_xqt_depay_base_init), (gst_rtp_xqt_depay_class_init), (gst_rtp_xqt_depay_init), (gst_rtp_xqt_depay_finalize), (gst_rtp_quicktime_parse_sd), (gst_rtp_xqt_depay_setcaps), (gst_rtp_xqt_depay_process), (gst_rtp_xqt_depay_set_property), (gst_rtp_xqt_depay_get_property), (gst_rtp_xqt_depay_change_state), (gst_rtp_xqt_depay_plugin_init): * gst/qtdemux/gstrtpxqtdepay.h: * gst/qtdemux/qtdemux.c: (gst_qtdemux_base_init), (gst_qtdemux_loop_state_header), (gst_qtdemux_loop), (qtdemux_parse_moov), (qtdemux_parse_container), (qtdemux_parse_node), (gst_qtdemux_add_stream), (qtdemux_parse_trak), (qtdemux_audio_caps): * gst/qtdemux/qtdemux.h: * gst/qtdemux/quicktime.c: (plugin_init): Add X-QT depayloader that will eventually share code with the demuxer. Make new plugin entry point with quicktime releated stuff.
Diffstat (limited to 'gst/qtdemux/Makefile.am')
-rw-r--r--gst/qtdemux/Makefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/gst/qtdemux/Makefile.am b/gst/qtdemux/Makefile.am
index 5d1792ec..2c4aa52a 100644
--- a/gst/qtdemux/Makefile.am
+++ b/gst/qtdemux/Makefile.am
@@ -1,14 +1,16 @@
plugin_LTLIBRARIES = libgstqtdemux.la
-libgstqtdemux_la_CFLAGS = ${GST_CFLAGS}
-libgstqtdemux_la_LIBADD = $(GST_BASE_LIBS) $(ZLIB_LIBS)
+libgstqtdemux_la_CFLAGS = ${GST_CFLAGS} $(GST_PLUGINS_BASE_CFLAGS)
+libgstqtdemux_la_LIBADD = $(GST_PLUGINS_BASE_LIBS) $(GST_BASE_LIBS) $(ZLIB_LIBS) \
+ -lgstrtp-@GST_MAJORMINOR@
libgstqtdemux_la_LDFLAGS = ${GST_PLUGIN_LDFLAGS}
-libgstqtdemux_la_SOURCES = qtdemux.c qtdemux_types.c qtdemux_dump.c
+libgstqtdemux_la_SOURCES = quicktime.c gstrtpxqtdepay.c qtdemux.c qtdemux_types.c qtdemux_dump.c
noinst_HEADERS = \
qtdemux.h \
qtdemux_types.h \
qtdemux_dump.h \
qtdemux_fourcc.h \
- qtpalette.h
+ qtpalette.h \
+ gstrtpxqtdepay.h