summaryrefslogtreecommitdiffstats
path: root/gst/rtsp/Makefile.am
diff options
context:
space:
mode:
authorWim Taymans <wim.taymans@gmail.com>2005-05-11 07:44:44 +0000
committerWim Taymans <wim.taymans@gmail.com>2005-05-11 07:44:44 +0000
commit6f0ea35883cec1b68eb1ac2f2bc511f856018f6f (patch)
tree601e40d1ac5cd282ad5f207f4a9a647da62fc126 /gst/rtsp/Makefile.am
parent6cacd6f64958db92328a9ae52563160a583a395a (diff)
Ported to 0.9.
Original commit message from CVS: Ported to 0.9. Set up transports, init UDP ports, init RTP session managers.
Diffstat (limited to 'gst/rtsp/Makefile.am')
-rw-r--r--gst/rtsp/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/gst/rtsp/Makefile.am b/gst/rtsp/Makefile.am
new file mode 100644
index 00000000..2a90944b
--- /dev/null
+++ b/gst/rtsp/Makefile.am
@@ -0,0 +1,22 @@
+
+plugin_LTLIBRARIES = libgstrtsp.la
+
+libgstrtsp_la_SOURCES = gstrtsp.c gstrtspsrc.c \
+ rtspconnection.c \
+ rtspdefs.c \
+ rtspmessage.c \
+ rtsptransport.c \
+ rtspurl.c \
+ sdpmessage.c
+
+libgstrtsp_la_CFLAGS = $(GST_CFLAGS)
+libgstrtsp_la_LIBADD =
+libgstrtsp_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+
+check_PROGRAMS = test
+
+test_SOURCES = test.c rtspdefs.c rtspurl.c rtspconnection.c rtspmessage.c rtsptransport.c sdpmessage.c
+test_CFLAGS = $(GST_CFLAGS)
+test_LDFLAGS = $(GST_LIBS)
+
+noinst_HEADERS = gstrtspsrc.h gstrtsp.h rtsptransport.h