summaryrefslogtreecommitdiffstats
path: root/gst/rtsp/Makefile.am
diff options
context:
space:
mode:
authorWim Taymans <wim.taymans@gmail.com>2006-02-09 14:20:14 +0000
committerWim Taymans <wim.taymans@gmail.com>2006-02-09 14:20:14 +0000
commit946e1e43637e78c263c82d449ec19dfd84ed8269 (patch)
tree79abf610349beae51daa2c53a10fbb45175cb797 /gst/rtsp/Makefile.am
parent509035fcdb2bc6237bf906aa5fb030dbf33852ba (diff)
gst/rtsp/: Resurected rtpdec to make rtspsrc happy again.
Original commit message from CVS: * gst/rtsp/Makefile.am: * gst/rtsp/gstrtpdec.c: (gst_rtpdec_get_type), (gst_rtpdec_class_init), (gst_rtpdec_init), (gst_rtpdec_getcaps), (gst_rtpdec_chain_rtp), (gst_rtpdec_chain_rtcp), (gst_rtpdec_set_property), (gst_rtpdec_get_property), (gst_rtpdec_change_state): * gst/rtsp/gstrtpdec.h: * gst/rtsp/gstrtsp.c: (plugin_init): * gst/rtsp/gstrtspsrc.c: (gst_rtspsrc_stream_configure_transport): * gst/rtsp/rtspconnection.c: (read_body), (rtsp_connection_receive): * gst/rtsp/rtspmessage.c: (rtsp_message_dump): Resurected rtpdec to make rtspsrc happy again. Skip attributes from the session id. Don't crash when dumping a message with an empty body.
Diffstat (limited to 'gst/rtsp/Makefile.am')
-rw-r--r--gst/rtsp/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/gst/rtsp/Makefile.am b/gst/rtsp/Makefile.am
index f2606183..85c2dad4 100644
--- a/gst/rtsp/Makefile.am
+++ b/gst/rtsp/Makefile.am
@@ -1,6 +1,7 @@
plugin_LTLIBRARIES = libgstrtsp.la
libgstrtsp_la_SOURCES = gstrtsp.c gstrtspsrc.c \
+ gstrtpdec.c \
rtspconnection.c \
rtspdefs.c \
rtspmessage.c \
@@ -18,4 +19,4 @@ test_SOURCES = test.c rtspdefs.c rtspurl.c rtspconnection.c rtspmessage.c rtsptr
test_CFLAGS = $(GST_CFLAGS)
test_LDFLAGS = $(GST_LIBS)
-noinst_HEADERS = gstrtspsrc.h gstrtsp.h rtsptransport.h rtsp.h rtspurl.h rtspconnection.h rtspdefs.h rtspmessage.h sdp.h sdpmessage.h
+noinst_HEADERS = gstrtspsrc.h gstrtsp.h gstrtpdec.h rtsptransport.h rtsp.h rtspurl.h rtspconnection.h rtspdefs.h rtspmessage.h sdp.h sdpmessage.h