summaryrefslogtreecommitdiffstats
path: root/gst/rtsp/Makefile.am
diff options
context:
space:
mode:
authorWim Taymans <wim.taymans@gmail.com>2006-07-10 16:41:57 +0000
committerWim Taymans <wim.taymans@gmail.com>2006-07-10 16:41:57 +0000
commitf08deb4345e4509f8e25cb9c3f10713246db6e36 (patch)
tree437857210a52b56bce3b811e38ed7d09efc39ae5 /gst/rtsp/Makefile.am
parent7089fbac56557b7dbf0b91201352797c89216ec6 (diff)
gst/rtsp/: replaced closesocket and close in code with one CLOSE_SOCKET.
Original commit message from CVS: * gst/rtsp/Makefile.am: * gst/rtsp/rtspconnection.c: (rtsp_connection_send), (rtsp_connection_close): * gst/rtsp/rtspdefs.h: replaced closesocket and close in code with one CLOSE_SOCKET. Some more cleanups. Fixes #345301.
Diffstat (limited to 'gst/rtsp/Makefile.am')
-rw-r--r--gst/rtsp/Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/gst/rtsp/Makefile.am b/gst/rtsp/Makefile.am
index 85c2dad4..86e0a2a2 100644
--- a/gst/rtsp/Makefile.am
+++ b/gst/rtsp/Makefile.am
@@ -2,21 +2,21 @@ plugin_LTLIBRARIES = libgstrtsp.la
libgstrtsp_la_SOURCES = gstrtsp.c gstrtspsrc.c \
gstrtpdec.c \
- rtspconnection.c \
- rtspdefs.c \
- rtspmessage.c \
+ rtspconnection.c \
+ rtspdefs.c \
+ rtspmessage.c \
rtsptransport.c \
rtspurl.c \
sdpmessage.c
libgstrtsp_la_CFLAGS = $(GST_CFLAGS)
-libgstrtsp_la_LIBADD = $(GST_LIBS)
+libgstrtsp_la_LIBADD = $(GST_LIBS) $(WIN32_LIBS)
libgstrtsp_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
check_PROGRAMS = test
test_SOURCES = test.c rtspdefs.c rtspurl.c rtspconnection.c rtspmessage.c rtsptransport.c sdpmessage.c
test_CFLAGS = $(GST_CFLAGS)
-test_LDFLAGS = $(GST_LIBS)
+test_LDFLAGS = $(GST_LIBS) $(WIN32_LIBS)
noinst_HEADERS = gstrtspsrc.h gstrtsp.h gstrtpdec.h rtsptransport.h rtsp.h rtspurl.h rtspconnection.h rtspdefs.h rtspmessage.h sdp.h sdpmessage.h