summaryrefslogtreecommitdiffstats
path: root/gst/udp/Makefile.am
diff options
context:
space:
mode:
authorWim Taymans <wim.taymans@gmail.com>2005-06-02 13:28:46 +0000
committerWim Taymans <wim.taymans@gmail.com>2005-06-02 13:28:46 +0000
commit8e61fd923091dbdb1cefe157c8dcfecc57d166fd (patch)
tree6ba8c2f83c2b13b90e857f9ec052b075de5d3655 /gst/udp/Makefile.am
parentca1f865eaa541789d704d0d90ec36001a17da3fd (diff)
gst/udp/: Use NetBuffer and small cleanups.
Original commit message from CVS: * gst/udp/Makefile.am: * gst/udp/gstmultiudpsink.c: (gst_multiudpsink_get_type), (gst_multiudpsink_base_init), (gst_multiudpsink_class_init), (gst_multiudpsink_init), (gst_multiudpsink_finalize), (gst_multiudpsink_get_times), (gst_multiudpsink_render), (gst_multiudpsink_set_property), (gst_multiudpsink_init_send), (gst_multiudpsink_add), (client_compare), (free_client), (gst_multiudpsink_remove), (gst_multiudpsink_clear), (gst_multiudpsink_get_stats): * gst/udp/gstudpsrc.c: (gst_udpsrc_get_type), (gst_udpsrc_base_init), (gst_udpsrc_class_init), (gst_udpsrc_create), (gst_udpsrc_set_uri), (gst_udpsrc_start), (gst_udpsrc_unlock), (gst_udpsrc_stop): Use NetBuffer and small cleanups. Implement client removal in multiudpsink.
Diffstat (limited to 'gst/udp/Makefile.am')
-rw-r--r--gst/udp/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/gst/udp/Makefile.am b/gst/udp/Makefile.am
index d88d1135..9f579ca5 100644
--- a/gst/udp/Makefile.am
+++ b/gst/udp/Makefile.am
@@ -13,9 +13,9 @@ built_headers = gstudp-enumtypes.h gstudp-marshal.h
BUILT_SOURCES = $(built_sources) $(built_headers)
libgstudp_la_SOURCES = gstudp.c gstudpsrc.c gstudpsink.c gstmultiudpsink.c
-libgstudp_la_CFLAGS = $(GST_CFLAGS)
+libgstudp_la_CFLAGS = $(GST_CFLAGS) $(GST_PLUGINS_LIBS_CFLAGS)
libgstudp_la_LIBADD =
-libgstudp_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS) $(GST_BASE_LIBS)
+libgstudp_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS) $(GST_BASE_LIBS) ../../../gst-plugins-base/gst-libs/gst/net/libgstnet.la
nodist_libgstudp_la_SOURCES = \
$(built_sources)