summaryrefslogtreecommitdiffstats
path: root/gst/videofilter/Makefile.am
diff options
context:
space:
mode:
authorDavid Schleef <ds@schleef.org>2003-07-02 06:16:39 +0000
committerDavid Schleef <ds@schleef.org>2003-07-02 06:16:39 +0000
commit1bdd2c9cc3732e2376fa0e731675c69d6245fa73 (patch)
treec271ff69bb5789d0c118a9b3901d187832ff50ee /gst/videofilter/Makefile.am
parent23e47de3324577cc2cb76a11f21ba80cceac14fc (diff)
Add videoflip, created from template.
Original commit message from CVS: Add videoflip, created from template.
Diffstat (limited to 'gst/videofilter/Makefile.am')
-rw-r--r--gst/videofilter/Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/gst/videofilter/Makefile.am b/gst/videofilter/Makefile.am
index 0fd9bfd7..e6c4c9ea 100644
--- a/gst/videofilter/Makefile.am
+++ b/gst/videofilter/Makefile.am
@@ -1,11 +1,12 @@
plugindir = $(libdir)/gstreamer-@GST_MAJORMINOR@
-plugin_LTLIBRARIES = libgstvideofilter.la
+plugin_LTLIBRARIES = libgstvideofilter.la libgstvideoflip.la
noinst_LTLIBRARIES = libgstvideoexample.la
-noinst_HEADERS = gstvideofilter.h gstvideoexample.h
+noinst_HEADERS = gstvideofilter.h gstvideoexample.h gstvideoflip.h
EXTRA_DIST = gstvideotemplate.c gstvideotemplate.h make_filter
+EXTRA_CLEAN = gstvideoexample.c gstvideoexample.h
libgstvideofilter_la_SOURCES = gstvideofilter.c
libgstvideofilter_la_CFLAGS = $(GST_CFLAGS)
@@ -17,6 +18,11 @@ libgstvideoexample_la_CFLAGS = $(GST_CFLAGS)
libgstvideoexample_la_LIBADD =
libgstvideoexample_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+libgstvideoflip_la_SOURCES = gstvideoflip.c
+libgstvideoflip_la_CFLAGS = $(GST_CFLAGS)
+libgstvideoflip_la_LIBADD =
+libgstvideoflip_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+
# no, this doesn't work if $(srcdir) != (builddir)
gstvideoexample.c gstvideoexample.h: $(srcdir)/make_filter \